POJ1308-----并查集基础题

Description

A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following properties.

There is exactly one node, called the root, to which no directed edges point.
Every node except the root has exactly one edge pointing to it.
There is a unique sequence of directed edges from the root to each node.
For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.

In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

Input

The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than zero.

Output

For each test case display the line "Case k is a tree." or the line "Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting with 1).

Sample Input

6 8  5 3  5 2  6 4
5 6  0 0

8 1  7 3  6 2  8 9  7 5
7 4  7 8  7 6  0 0

3 8  6 8  6 4
5 3  5 6  5 2  0 0
-1 -1

Sample Output

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.



坑爹的带方向的树(与小西的迷宫很多都一样)
1.不能成环
2.0 0这种空树也算树
3.输入的时候不能出现两个不同的点同时指向一个点,类似(1 2)(3 2)这种,1 --> 2同时3 --> 2是不行的,但是2 --> 1 和 2 --> 3,一个数指向两个数是可以的
4.必须只有一个根, 不能出现多个根



#include<cstdio>
#include<cstring>
#define N 10002
int n, cnt[N], ans[N];
int find(int a){
    return a == ans[a] ? a : (ans[a] = find(ans[a]));//压缩路径
}
void merge(int a, int b){
    int fx = find(a), fy = find(b);
    if(fx != fy){
        ans[fy] = fx;
        return ;
    }
    n = 1;//判断是否成环
}
int main(){
    int m = 1, x, y, c = 0;//用c来判断 0 0 这种输入
    memset(cnt, 0, sizeof(cnt));
    memset(ans, 0, sizeof(ans));
    while(scanf("%d%d", &x, &y) == 2 && x + y != -2){
        if(x + y == 0){
            int k = 0;
            for(int i = 1; i < N; i++){
                if(ans[i] == i){
                    k++;
                }
            }
            if((!n && k == 1) || !c){//Case后边加了个冒号,找bug弄了老长时间,气死我了
            	printf("Case %d is a tree.\n", m++);
			}
            else{
            	printf("Case %d is not a tree.\n", m++);
			}
            memset(cnt, 0, sizeof(cnt));
            memset(ans, 0, sizeof(ans));
            c = n = 0;//清零,WA了好几次就栽在这里
            continue;
        }
        c++;
        cnt[y]++;//cnt函数判断是否两个数指向同一个数
        if(!ans[x]){//不用pre[]来遍历进行初始化,直接在根数组里初始化
            ans[x] = x;
        }
        if(!ans[y]){
            ans[y] = y;
        }
        if(cnt[y] > 1){//成环或输入两个数指向同一个数时不再遍历,直接下一循环
            n = 1;
            continue;
        }
        merge(x, y);
    }
    return 0;
}





 
坑爹的带方向的树(与小西的迷宫很多都一样)
1.不能成环
2.0 0这种空树也算树
3.输入的时候不能出现两个不同的点同时指向一个点,类似(1 2)(3 2)这种,1 --> 2同时3 --> 2是不行的,但是2 --> 1 和 2 --> 3,一个数指向两个数是可以的
4.必须只有一个根, 不能出现多个根
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值