POJ-----2251BFS

Dungeon Master
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 26433 Accepted: 10292

Description

You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides. 

Is an escape possible? If yes, how long will it take? 

Input

The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size). 
L is the number of levels making up the dungeon. 
R and C are the number of rows and columns making up the plan of each level. 
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output

Each maze generates one line of output. If it is possible to reach the exit, print a line of the form 
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape. 
If it is not possible to escape, print the line 
Trapped!

Sample Input

3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0

Sample Output

Escaped in 11 minute(s).
Trapped!

就记得同学在我旁边跟我说,快做这个,这个简单,BFS入门级水题-----

没什么技巧,就是模板


#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#include<algorithm>
using namespace std;
char s[40][40][40];
int ss[40][40][40], L, R, C, X, Y, Z;
int sss[10][3] = {0, 0, 1, 0, 0, -1, 0, -1, 0, 0, 1, 0, 1, 0, 0, -1, 0, 0};
struct node{
	int x, y, z, step;
}v, n, t, r;
bool judge(node v){
	if(v.x < 0 || v.y < 0 || v.z < 0){
		return false;
	}
	if(v.x >= L || v.y >= R || v.z >= C){
		return false;
	}
	if(s[v.x][v.y][v.z] == '#' || ss[v.x][v.y][v.z]){
		return false;
	}
	return true;
}
void dfs(){
	queue<node > q;
	n.x = X;
	n.y = Y;
	n.z = Z;
	n.step = 0;
	q.push(n);
	s[X][Y][Z] = 1;
	while(!q.empty()){
		t = q.front();
		r = t;
		q.pop();
		for(int i = 0; i < 6; i++){
			r.x = t.x + sss[i][0];
			r.y = t.y + sss[i][1];
			r.z = t.z + sss[i][2];
			r.step = t.step+1;
			if(judge(r)){
				if(s[r.x][r.y][r.z] == 'E'){
					printf("Escaped in %d minute(s).\n", r.step);
					return ;
				}
				ss[r.x][r.y][r.z] = 1;
				q.push(r);
			}
		}
	}
	printf("Trapped!\n");
}
int main(){
	while(~scanf("%d%d%d", &L, &R, &C), R || L || C){
		int o = 0;
		for(int i = 0; i < L; i++){
			for(int j = 0; j < R; j++){
				scanf(" %s", s[i][j]);
				if(!o){
					for(int k = 0; k < C; k++){
						if(s[i][j][k] == 'S'){
							X = i;
							Y = j;
							Z = k;
							o++;
						}
					}
				}
			}
		}
		memset(ss, 0, sizeof(ss));
		dfs();
	}
	return 0;
}


Stkcd [股票代码] ShortName [股票简称] Accper [统计截止日期] Typrep [报表类型编码] Indcd [行业代码] Indnme [行业名称] Source [公告来源] F060101B [净利润现金净含量] F060101C [净利润现金净含量TTM] F060201B [营业收入现金含量] F060201C [营业收入现金含量TTM] F060301B [营业收入现金净含量] F060301C [营业收入现金净含量TTM] F060401B [营业利润现金净含量] F060401C [营业利润现金净含量TTM] F060901B [筹资活动债权人现金净流量] F060901C [筹资活动债权人现金净流量TTM] F061001B [筹资活动股东现金净流量] F061001C [筹资活动股东现金净流量TTM] F061201B [折旧摊销] F061201C [折旧摊销TTM] F061301B [公司现金流1] F061302B [公司现金流2] F061301C [公司现金流TTM1] F061302C [公司现金流TTM2] F061401B [股权现金流1] F061402B [股权现金流2] F061401C [股权现金流TTM1] F061402C [股权现金流TTM2] F061501B [公司自由现金流(原有)] F061601B [股权自由现金流(原有)] F061701B [全部现金回收率] F061801B [营运指数] F061901B [资本支出与折旧摊销比] F062001B [现金适合比率] F062101B [现金再投资比率] F062201B [现金满足投资比率] F062301B [股权自由现金流] F062401B [企业自由现金流] Indcd1 [行业代码1] Indnme1 [行业名称1] 季度数据,所有沪深北上市公司的 分别包含excel、dta数据文件格式及其说明,便于不同软件工具对数据的分析应用 数据来源:基于上市公司年报及公告数据整理,或相关证券交易所、各部委、省、市数据 数据范围:基于沪深北证上市公司 A股(主板、中小企业板、创业板、科创板等)数据整理计算
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值