POJ-----3278BFS

Catch That Cow
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 74836 Accepted: 23623

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers:  N and  K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

农民要追上一头牛,给定两人位置,问最少要多久追上,抽象成一个坐标轴,农民只能坐标+1,-1或*2,简单BFS,还是模板


#include<cstdio>
#include<queue>
#include<algorithm>
#include<cstring>
using namespace std;
#define maxn 100010
int ans, n, k;
bool vis[maxn];
struct node{
	int x, step;
}t, r;
bool judge(node v){
	if(v.x < 0 || v.x > maxn || vis[v.x]){
		return false;
	}
	return true;
}
queue<node > q;
void bfs(){
	t.x = n;
	t.step = 0;
	q.push(t);
	vis[t.x] = true;
	while(!q.empty()){
		t = q.front();
		q.pop();
		for(int i = 0; i < 3; i++){
			if(i == 0){
				r.x = t.x+1;
			}
			if(i == 1){
				r.x = t.x-1;
			}
			if(i == 2){
				r.x = t.x*2;
			}
			if(judge(r)){
				r.step = t.step+1;
				if(r.x == k){
					printf("%d\n", r.step);
					return ;
				}
				vis[r.x] = true;
				q.push(r);
			}
		}
	}
}
int main(){
	memset(vis, false, sizeof(vis));
	scanf("%d%d", &n, &k);
	if(n >= k){
		printf("%d\n", n-k);
	}
	else{
		bfs();
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值