POJ-----1985树的直径

Cow Marathon
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 5054 Accepted: 2459
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and 3 to farm 5 and is of length 20+3+13+9+7=52. 

就是求树中最长的一条路,也叫树的直径,反证法证明,证明就略了,问数学老师都能问出来--

主要是实现,用到了邻接表对图的储存,也是一个基础模板,先任选一个点计算它的最长路,这条路的终点就是整个树直径的一个端点,在计算这个端点就可以求出另一个端点,通过邻接表就可以计算出每个点距离端点的距离,也就是可以求出一个端点到另一个端点的距离,核心就是邻接表对图的储存,理解了就很简单,不然晕乎乎的

这道题输入那个字符E,N什么的没看出什么用,自动忽略

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#define maxn 100100
using namespace std;
int ans, num, nod, x, y;
int head[maxn], dis[maxn];
bool vis[maxn];
struct node{
	int from, to, val, next;
}edge[maxn*2];
void add(int u, int v, int w){
	edge[num].from = u;
	edge[num].to = v;
	edge[num].val = w;
	edge[num].next = head[u];
	head[u] = num++;
}
void bfs(int t){
	memset(vis, false, sizeof(vis));
	memset(dis, 0, sizeof(dis));
	queue<int > q;
	q.push(t);
	ans = dis[t] = 0;
	vis[t] = true;
	while(!q.empty()){
		int u = q.front();
		q.pop();
		for(int i = head[u]; i != -1; i = edge[i].next){
			int v = edge[i].to;
			if(!vis[v]){
				if(dis[v] < edge[i].val + dis[u]){
					dis[v] = edge[i].val + dis[u];
				}
				q.push(v);
				vis[v] = true;
			}
		}
	}
	for(int i = 0; i <= x; i++){
		if(ans < dis[i]){
			ans = dis[i];
			nod = i;
		}
	}
}
int main(){
	int a, b, c;
	char ch;
	while(~scanf("%d%d", &x, &y)){
		memset(head, -1, sizeof(head));
		num = 0;
		for(int i = 0; i < y; i++){
			scanf("%d%d%d %c", &a, &b, &c, &ch);
			add(a, b, c);
			add(b, a, c);
		}
		bfs(1);
		bfs(nod);
		printf("%d\n", ans);
	}
	return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值