HDOJ-----2602Bone Collector(DP-----01背包)

Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 51860    Accepted Submission(s): 21837


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2 31).
 

Sample Input
  
  
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
  
  
14

题:图不重要,看字

就是某人有体积为v的袋子,要捡骨头,给出n块骨头的价值与体积,问最多拿到多少价值的骨头---恶趣味

01背包模型

先给出二维的吧,二维时/空间都不能压缩

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
#define inf 0x3f3f3f3f
#define mes(a, b) memset(a, b, sizeof(a))
#define maxn 1010
using namespace std;
int ans, m, n, v;
int val[maxn], vol[maxn], dp[maxn][maxn];
int main(){
    int t;
    scanf("%d", &t);
    while(t--){
        mes(val, 0);
        mes(vol, 0);
        mes(dp, 0);
        scanf("%d%d", &n, &v);
        for(int i = 1; i <= n; i++){
            scanf("%d", &val[i]);
        }
        for(int i = 1; i <= n; i++){
            scanf("%d", &vol[i]);
        }
        for(int i = 1; i <= n; i++){
            for(int j = 0; j <= v; j++){
                if(j >= vol[i]){
                    dp[i][j] = max(dp[i-1][j], dp[i-1][j-vol[i]]+val[i]);
                }
                else{
                    dp[i][j] = dp[i-1][j];
                }
            }
        }
        printf("%d\n", dp[n][v]);
    }
    return 0;
}

一维的,略微压缩时间与空间

#include<cstdio>
#include<cstring>
#include<algorithm>
#define ll long long
#define inf 0x3f3f3f3f
#define mes(a, b) memset(a, b, sizeof(a))
#define maxn 1010
using namespace std;
int ans, m, n, v;
int val[maxn], vol[maxn], dp[maxn];
int main(){
    int t;
    scanf("%d", &t);
    while(t--){
        mes(val, 0);
        mes(vol, 0);
        mes(dp, 0);
        scanf("%d%d", &n, &v);
        for(int i = 1; i <= n; i++){
            scanf("%d", &val[i]);
        }
        for(int i = 1; i <= n; i++){
            scanf("%d", &vol[i]);
        }
        for(int i = 1; i <= n; i++){
            for(int j = v; j >= 0; j--){
                if(j >= vol[i]){
                    dp[j] = max(dp[j], dp[j-vol[i]]+val[i]);
                    continue;
                }
                break;
            }
        }
        printf("%d\n", dp[v]);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值