POJ-----1006---Biorhythms扩展欧几里得

Biorhythms
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 131903 Accepted: 42066

Description

Some people believe that there are three cycles in a person's life that start the day he or she is born. These three cycles are the physical, emotional, and intellectual cycles, and they have periods of lengths 23, 28, and 33 days, respectively. There is one peak in each period of a cycle. At the peak of a cycle, a person performs at his or her best in the corresponding field (physical, emotional or mental). For example, if it is the mental curve, thought processes will be sharper and concentration will be easier.
Since the three cycles have different periods, the peaks of the three cycles generally occur at different times. We would like to determine when a triple peak occurs (the peaks of all three cycles occur in the same day) for any person. For each cycle, you will be given the number of days from the beginning of the current year at which one of its peaks (not necessarily the first) occurs. You will also be given a date expressed as the number of days from the beginning of the current year. You task is to determine the number of days from the given date to the next triple peak. The given date is not counted. For example, if the given date is 10 and the next triple peak occurs on day 12, the answer is 2, not 3. If a triple peak occurs on the given date, you should give the number of days to the next occurrence of a triple peak.

Input

You will be given a number of cases. The input for each case consists of one line of four integers p, e, i, and d. The values p, e, and i are the number of days from the beginning of the current year at which the physical, emotional, and intellectual cycles peak, respectively. The value d is the given date and may be smaller than any of p, e, or i. All values are non-negative and at most 365, and you may assume that a triple peak will occur within 21252 days of the given date. The end of input is indicated by a line in which p = e = i = d = -1.

Output

For each test case, print the case number followed by a message indicating the number of days to the next triple peak, in the form:

Case 1: the next triple peak occurs in 1234 days.

Use the plural form ``days'' even if the answer is 1.

Sample Input

0 0 0 0
0 0 0 100
5 20 34 325
4 5 6 7
283 102 23 320
203 301 203 40
-1 -1 -1 -1

Sample Output

Case 1: the next triple peak occurs in 21252 days.
Case 2: the next triple peak occurs in 21152 days.
Case 3: the next triple peak occurs in 19575 days.
Case 4: the next triple peak occurs in 16994 days.
Case 5: the next triple peak occurs in 8910 days.
Case 6: the next triple peak occurs in 10789 days.

每人有三种周期,体能,情感,智力周期,三种周期分别是23,28,33天,每种周期之中存在一个波峰

给出4个数,前三个分别是三个周期三个波峰的日期(不一定是第一个),对周期取余,即可得到峰值在周期中的位置

第4个数指从当前日期,问从当期日期到下一个三连峰(三峰值同一天)的时间,如果今天就是三连峰,计算下一个三连峰的值

由此可得

23*x+a=365*n

28*y+b=365*n

33*z+c=365*n

联立

23*x+a=28*y+b

23*x-28y=b-a

可由扩展欧几里得求得x和y的最小整数解,再带入原式,可求出n的一个最小整数解,组成一个新的式子,再联立第三个即可

(参考前两篇博客,不再赘述)

#include<cstdio>
#include<iostream>
#include<cmath>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
#include<set> 
#include<queue>
#include<vector>
#include<functional>
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define CL(a, b) memset(a, b, sizeof(a))
using namespace std;
typedef long long LL;
const int maxn = 1e5+10;
const int MOD = 1e9+7; 
void ex_gcd(int a, int b, int& d, int& x, int& y){
	if(!b){
		d = a;
		x = 1;
		y = 0;
	}
	else{
		ex_gcd(b, a%b, d, y, x);
		y -= x*(a/b);
	}
}
int main(){
	int d, x, y, m1, m2, m3, n1, n2, n3, v;
	int kcase = 1;
	while(scanf("%d%d%d%d", &n1, &n2, &n3, &v) == 4){
		if(n1 < 0 && n2 < 0 && n3 < 0 && v < 0) break;
		m1 = 23; m2 = 28; m3 = 33;
		n1 %= 23; n2 %= 28; n3 %= 33;
		ex_gcd(m1, m2, d, x, y);//两次联立即可
		LL c, t, k;
		c = n2-n1;
		c /= d;
		t = m2/d;
		x *= c;
		k = (x%t+t)%t;
		n1 += m1*k; 
		m1 = m1/d*m2;
		n1 = (n1%m1+m1)%m1;
		
		ex_gcd(m1, m3, d, x, y);
		c = n3-n1;
		c /= d;
		t = m3/d;
		x *= c;
		k = (x%t+t)%t;
		n1 += m1*k; 
		m1 = m1/d*m3;
		n1 = (n1%m1+m1)%m1;
		while(n1 <= v) n1 += m1;//计算下一次三连峰
		printf("Case %d: the next triple peak occurs in %d days.\n", kcase++, n1-v);
	}
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值