POJ-----2253---Frogger---最短路

Frogger
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 41816 Accepted: 13374

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping.
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence.
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414


给出n个坐标,前两个表示青蛙a,b的坐标,接下来表示石头的坐标,青蛙a可以跳石头来到达青蛙b,问所有道路中最长边最小的那条边,把最短路模型修改一下,dis[i]从表示起点到当前点的最短距离变成从起点到当前点的最长边的长度,即不需要总长度最短,只需要最长边最短即可

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<queue>
#include<cmath>
#include<algorithm>
#define inf 0x3f3f3f3f
using namespace std;
typedef long long  LL;
const int maxn = 5e5+10;
bool vis[maxn];
double map[210][210], dis[maxn];
struct node{
	int x, y;
} s[210];
void spfa(int n){
	for(int i = 2; i <= n; i++){
		vis[i] = false;
		dis[i] = inf;
	}
	queue <int> q;
	q.push(1);
	dis[1] = 0;
	while(!q.empty()){
		int u = q.front();
		q.pop();
		vis[u] = false;
		for(int v = 1; v <= n; v++){
			if(dis[v] > max(dis[u], map[u][v])){
				dis[v] = max(dis[u], map[u][v]);
				if(!vis[v]){
					vis[v] = true;
					q.push(v);
				}
			}
		}
	}
}
int main(){ 
    int t, n, kcase = 1;
    while(scanf("%d", &n) == 1 && n){
    	for(int i = 1; i <= n; i++) scanf("%d%d", &s[i].x, &s[i].y);
    	for(int i = 1; i <= n; i++){
    		for(int j = i+1; j <= n; j++){
    			map[i][j] = map[j][i] = sqrt(1.0*(s[i].x-s[j].x)*(s[i].x-s[j].x) + 1.0*(s[i].y-s[j].y)*(s[i].y-s[j].y));
			}
		}
    	spfa(n);
    	printf("Scenario #%d\nFrog Distance = %.3lf\n\n", kcase++, dis[2]);
	}
    return 0;  
}  
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值