poj1459——Power Network(网络流,超级源点、汇点)

Description

A power network consists of nodes (power stations, consumers and dispatchers) connected by power transport lines. A node u may be supplied with an amount s(u) >= 0 of power, may produce an amount 0 <= p(u) <= pmax(u) of power, may consume an amount 0 <= c(u) <= min(s(u),cmax(u)) of power, and may deliver an amount d(u)=s(u)+p(u)-c(u) of power. The following restrictions apply: c(u)=0 for any power station, p(u)=0 for any consumer, and p(u)=c(u)=0 for any dispatcher. There is at most one power transport line (u,v) from a node u to a node v in the net; it transports an amount 0 <= l(u,v) <= lmax(u,v) of power delivered by u to v. Let Con=Σuc(u) be the power consumed in the net. The problem is to compute the maximum value of Con.

这里写图片描述
An example is in figure 1. The label x/y of power station u shows that p(u)=x and pmax(u)=y. The label x/y of consumer u shows that c(u)=x and cmax(u)=y. The label x/y of power transport line (u,v) shows that l(u,v)=x and lmax(u,v)=y. The power consumed is Con=6. Notice that there are other possible states of the network but the value of Con cannot exceed 6.
Input

There are several data sets in the input. Each data set encodes a power network. It starts with four integers: 0 <= n <= 100 (nodes), 0 <= np <= n (power stations), 0 <= nc <= n (consumers), and 0 <= m <= n^2 (power transport lines). Follow m data triplets (u,v)z, where u and v are node identifiers (starting from 0) and 0 <= z <= 1000 is the value of lmax(u,v). Follow np doublets (u)z, where u is the identifier of a power station and 0 <= z <= 10000 is the value of pmax(u). The data set ends with nc doublets (u)z, where u is the identifier of a consumer and 0 <= z <= 10000 is the value of cmax(u). All input numbers are integers. Except the (u,v)z triplets and the (u)z doublets, which do not contain white spaces, white spaces can occur freely in input. Input data terminate with an end of file and are correct.
Output

For each data set from the input, the program prints on the standard output the maximum amount of power that can be consumed in the corresponding network. Each result has an integral value and is printed from the beginning of a separate line.
Sample Input

2 1 1 2 (0,1)20 (1,0)10 (0)15 (1)20
7 2 3 13 (0,0)1 (0,1)2 (0,2)5 (1,0)1 (1,2)8 (2,3)1 (2,4)7
(3,5)2 (3,6)5 (4,2)7 (4,3)5 (4,5)1 (6,0)5
(0)5 (1)2 (3)2 (4)1 (5)4
Sample Output

15
6

题意比较难懂。而且很多废话,直接看输入。先是四个数n,np,nc,m,n表示节点,有发电厂,变压器,用户等等;接下来是m对数,括号里是路径,然后就是流量;接下来是np个数,括号里是发电厂的位置,外面是它的容量;最后是nc个数,表示用户的位置和容量。
容易看出发电厂和用户的个数有很多个,所以要建立超级源点连接所有发电厂,发电厂的容量表示路径的流量。同理用超级汇点连接所有用户,用户的容量表示路径的流量。接着用最大流解决

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
#include <vector>
#include <iostream>
#include <set>
#include <cstring>
#include <string>
#define MAXN 510
#define inf 0x3f3f3f3f
using namespace std;
int n,np,nc,m;
int flow[MAXN][MAXN],cap[MAXN][MAXN],pre[MAXN],a[MAXN]; //流量,容量,父节点,残量
void EdmondsKarp(int s,int t)
{
    int u,v;
    queue<int> q;
    int f=0;
    while(1)
    {
        memset(a,0,sizeof(a));
        q.push(s);
        a[s]=inf;
        while(!q.empty()) //bfs找增光路径
        {
            u=q.front();
            q.pop();
            for(v=0; v<=n+1; ++v)
            {
                if(a[v]==0&&cap[u][v]>flow[u][v])
                {
                    pre[v]=u;
                    a[v]=min(a[u],cap[u][v]-flow[u][v]); //找到s-v路径的最小残量
                    q.push(v);
                }
            }
        }
        if(a[t]==0) //所有路径的残量都为0,说明已经是最大流
            break;
        for(v=t; v!=s; v=pre[v]) //更新路径的流量
        {
            flow[pre[v]][v]+=a[t];
            flow[v][pre[v]]-=a[t];
        }
        f+=a[t];
    }
    printf("%d\n",f);
}
int main()
{
    int u,v,w;
    char ch;
    while(~scanf("%d%d%d%d",&n,&np,&nc,&m))
    {
        memset(cap,0,sizeof(cap));
        memset(flow,0,sizeof(flow));
        for(int i=0; i<m; ++i) //输入路径,要预留超级源点的位置
        {
            cin>>ch>>u>>ch>>v>>ch>>w;
            cap[u+1][v+1]=w;
        }
        for(int i=0;i<np;++i)
        {
            cin>>ch>>u>>ch>>w; //发电厂的位置,从超级源点0开始
            cap[0][u+1]=w;
        }
        for(int i=0;i<nc;++i) //用户的位置,到达超级汇点n+1
        {
            cin>>ch>>u>>ch>>w;
            cap[u+1][n+1]=w;
        }
        EdmondsKarp(0,n+1);
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值