poj3096——Surprising Strings(STL)

Description

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the “Puzzling Adventures” column in the December 2003 issue of Scientific American.

Input

The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.

Output

For each string of letters, output whether or not it is surprising using the exact output format shown below.

Sample Input

ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*
Sample Output

ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

给出一段字符串,D-pair表示字符串中相距为D的两个字符,比如ABC的0-pair是AB和AC,同理1-pair是AC。
如果这个字符串的每个D-pair都不相同,那这个字符串就是surprising的,
ABAB就不是,因为0-pair有两个AB
题目求一个字符串是不是surprising的,用set保存出现过的pair就行了

#include <iostream>
#include <cstring>
#include <string>
#include <vector>
#include <queue>
#include <cstdio>
#include <set>
#include <math.h>
#include <algorithm>
#include <queue>
#include <iomanip>
#include <map>
#include <cctype>
#define INF 0x3f3f3f3f
#define MAXN 1000005
#define Mod 1000000007
using namespace std;
char s[100];
set<string> table;
int main()
{
    while(~scanf("%s",s))
    {
        if(s[0]=='*')
            break;
        int len=strlen(s),flag;
        for(int i=0;i<=len-2;++i)
        {
            table.clear();
            flag=0;
            for(int j=0;j+i+1<len;++j)
            {
                string tmp="";
                tmp+=s[j];
                tmp+=s[j+i+1];
                //cout<<tmp<<" ";
                if(table.find(tmp)==table.end())
                    table.insert(tmp);
                else
                    flag=1;
                if(flag)
                    break;
            }
            //cout<<endl;
            if(flag)
                break;
        }
        if(flag)
            cout<<s<<" is NOT surprising."<<endl;
        else
            cout<<s<<" is surprising."<<endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值