hdoj 1865 1sting 【大数斐波那契】

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4763    Accepted Submission(s): 1784


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
  
  
3 1 11 11111
 

Sample Output
  
  
1 2 8
 

Author
z.jt
 

Source

和nyoj655 一样,今天又打了一遍,还是有破洞--------

#include <cstdio>
#include <cstring>
int a[210][110];
void f()
{
    int p,q;
    memset(a,0,sizeof(a));//数组清零
    a[1][0]=1;
    a[2][0]=2;
    for(int i=3;i<205;i++)//斐波那契打表
    {
        p=q=0;
        for(int j=0;j<101;j++)
        {
            p=a[i-1][j]+a[i-2][j]+q;
            a[i][j]=p%10;
            q=p/10;
        }
    }
}
int main()
{
    f();//函数引用
    int t;
    char s[210];
    scanf("%d",&t);
    while(t--)
    {
        getchar();//!!
        scanf("%s",s);
        int len=strlen(s);
        int m;
        for(int i=100;i>=0;i--)//i开始赋值了200。。。这里是寻找的列数。。。
        {
            if(a[len][i]!=0)
            {
                m=i;
                break;
            }
        }
        for(int j=m;j>=0;j--)
        {
            printf("%d",a[len][j]);
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值