(二)S - S Lightoj 1008 【规律】

S - S
Time Limit:500MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu

Description

Fibsieve had a fantabulous (yes, it's an actual word) birthday party this year. He had so many gifts that he was actually thinking of not having a party next year.

Among these gifts there was an N x N glass chessboard that had a light in each of its cells. When the board was turned on a distinct cell would light up every second, and then go dark.

The cells would light up in the sequence shown in the diagram. Each cell is marked with the second in which it would light up.

(The numbers in the grids stand for the time when the corresponding cell lights up)

In the first second the light at cell (1, 1) would be on. And in the 5th second the cell (3, 1) would be on. Now, Fibsieve is trying to predict which cell will light up at a certain time (given in seconds). Assume that N is large enough.

Input

Input starts with an integer T (≤ 200), denoting the number of test cases.

Each case will contain an integer S (1 ≤ S ≤ 1015) which stands for the time.

Output

For each case you have to print the case number and two numbers (x, y), the column and the row number.

Sample Input

3

8

20

25

Sample Output

Case 1: 2 3

Case 2: 5 4

Case 3: 1 5


题意:找所给数的x y 坐标

题解:可以发现(n-1)^2+1--n^2的数可以看成一组,可以将已知数与对角线的数比较,然后求解


代码:

#include <cstdio>
#include <cmath>
int main()
{
    int t,x,y,k=1;
    long long s,n,m;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&s);
        n=sqrt(s);//组数
        if(s-n*n>0)
            n+=1;
        m=n*n-(n-1);//对角线数
        if(n%2==1)//组数为奇数
        {
            if(s>m)//大于对角线数
            {
                x=n-(s-m);
                y=n;
            }
            else//小于等于对角线数
            {
                y=n-(m-s);
                x=n;
            }
        }
        else//组数为偶数
        {
            if(s>m)
            {
                y=n-(s-m);
                x=n;
            }
            else
            {
                x=n-(m-s);
                y=n;
            }
        }
        printf("Case %d: %d %d\n",k++,x,y);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值