Time Limit: 2000MS | Memory Limit: 65536K | |
Total Submissions: 6412 | Accepted: 2566 |
Description
Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.
Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.
Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.
Input
Lines 2.. N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow's characteristics
Output
Sample Input
6 3 1 2 5 2 3 3 2 4 1 1 6
Sample Output
86
Hint
推一下,既要破坏程度小,又要运输时间短,那就试试按 破坏力 / 运输时间排序
开始思路有错了,只想成按时间或破坏力的情况了
贪心还是多多假设证明吧!
大神的证明:
假设牛a、b,距离为a,b,单位时间吃掉的花为da,db。 则先将a运回牛房,a、b共同吃掉的花是ya = a * da + (2 * a + b) * db 先将b运回牛房,a、b共同吃掉的花yb = b * db + (2 * b + a) * da yb - ya = 2 * (b * da - a * db) 当yb > ya, 即(b * da)/(a * db) > 1,即(b/db)>(a/da)时,先先将a运回牛房时间较短。 同理,当yb < ya, 即(b/db)<(a/da)时,现将b运回去时间较短。 当ya == yb时,运哪个都一样。 所以,可以将(x/dx)作为决策变量,这个值较小的先运回去。 |
#include<cstdio>
#include<algorithm>
using namespace std;
struct Node{
__int64 t,d;
}niu[100000+10];
bool cmp(Node x,Node y)
{
return x.d*y.t>x.t*y.d;
}
int main()
{
int n;
__int64 sum,ans;
while(~scanf("%d",&n))
{
sum=0;ans=0;
for(int i=0;i<n;i++)
{
scanf("%I64%I64",&niu[i].t,&niu[i].d);
sum+=niu[i].d;
}
sort(niu,niu+n,cmp);
for(int i=0;i<n-1;i++)
{
sum-=niu[i].d;
ans+=sum*niu[i].t*2;
}
printf("%I64\n",ans);
}
return 0;
}