hdoj 2141 Can you find it? 【二分查找】

Can you find it?

Time Limit: 10000/3000 MS (Java/Others)    Memory Limit: 32768/10000 K (Java/Others)
Total Submission(s): 23825    Accepted Submission(s): 6039


Problem Description
Give you three sequences of numbers A, B, C, then we give you a number X. Now you need to calculate if you can find the three numbers Ai, Bj, Ck, which satisfy the formula Ai+Bj+Ck = X.
 

Input
There are many cases. Every data case is described as followed: In the first line there are three integers L, N, M, in the second line there are L integers represent the sequence A, in the third line there are N integers represent the sequences B, in the forth line there are M integers represent the sequence C. In the fifth line there is an integer S represents there are S integers X to be calculated. 1<=L, N, M<=500, 1<=S<=1000. all the integers are 32-integers.
 

Output
For each case, firstly you have to print the case number as the form "Case d:", then for the S queries, you calculate if the formula can be satisfied or not. If satisfied, you print "YES", otherwise print "NO".
 

Sample Input
  
  
3 3 3 1 2 3 1 2 3 1 2 3 3 1 4 10
 

Sample Output
  
  
Case 1: NO YES NO
题目数据不算大,但是变量多啊,如果强制输入查找一定会暴,这题二分查找,对a[ ],b[ ]数组之和d[ ]查找可以省时间 
代码:

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;

int main()
{
    int l,n,m,a[505],b[505],c[505],d[250005];
    int s,x,cnt=0;
    while(~scanf("%d%d%d",&l,&n,&m))
    {
        int ans=0;
        for(int i=0;i<l;i++)
            scanf("%d",&a[i]);
        for(int j=0;j<n;j++)
        {
             scanf("%d",&b[j]);
             for(int i=0;i<l;i++)
                d[ans++]=a[i]+b[j];
        }
        for(int k=0;k<m;k++)
            scanf("%d",&c[k]);
        sort(d,d+ans);
        scanf("%d",&s);
        printf("Case %d:\n",++cnt);
        for(int i=0;i<s;i++)
        {
                scanf("%d",&x);
                int flag=0;
                for(int k=0;k<m;k++)
                {
                    int left=0,right=ans-1,mid;
                    while(left<=right)
                    {
                        mid=(left+right)/2;
                        if(c[k]+d[mid]==x)
                        {
                            flag=1;
                            break;
                        }
                        else if(c[k]+d[mid]<x)
                            left=mid+1;
                        else
                            right=mid-1;
                    }
                    if(flag)//没有这一步竟然超时了 
                    	break;
                }
                if(flag)
                    printf("YES\n");
                else
                    printf("NO\n");
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值