hdoj The Frog's Games (二分查找)

The Frog's Games

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 5592    Accepted Submission(s): 2697


Problem Description
The annual Games in frogs' kingdom started again. The most famous game is the Ironfrog Triathlon. One test in the Ironfrog Triathlon is jumping. This project requires the frog athletes to jump over the river. The width of the river is L (1<= L <= 1000000000). There are n (0<= n <= 500000) stones lined up in a straight line from one side to the other side of the river. The frogs can only jump through the river, but they can land on the stones. If they fall into the river, they 
are out. The frogs was asked to jump at most m (1<= m <= n+1) times. Now the frogs want to know if they want to jump across the river, at least what ability should they have. (That is the frog's longest jump distance).
 

Input
The input contains several cases. The first line of each case contains three positive integer L, n, and m. 
Then n lines follow. Each stands for the distance from the starting banks to the nth stone, two stone appear in one place is impossible.
 

Output
For each case, output a integer standing for the frog's ability at least they should have.
 

Sample Input
  
  
6 1 2 2 25 3 3 11 2 18
 

Sample Output
  
  
4 11
 

Source

The 36th ACM/ICPC Asia Regional Dalian Site —— Online Contest

题意:一条长为L的河, 已知N个石头到河的一边的距离,问跳M次到另一边的最小的距离

重要的是找到查找对象,本题是要查找判断mid是否满足跳跃次数是否<=m,

#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int s[500010];
int l,n,m;
int judge(int x)
{
    int ans=0;
    int pos=0;
    for(int i=1;i<=n;i++)
    {
        if(s[i]-s[pos]<=x&&s[i+1]-s[pos]>x)
        {
            ans++;
            pos=i;//更新起点
        }
    }
    ans++;
    if(ans<=m)
        return 1;//可行返回真
    else
        return 0;//不可行返回假
}
int main()
{
   int left,right,mid,c,max;
   while(~scanf("%d%d%d",&l,&n,&m))
   {
       s[0]=0;
       for(int i=1;i<=n;i++)
            scanf("%d",&s[i]);
        s[n+1]=l;
        sort(&s[1],&s[n+1]);
        max=0;
        for(int i=1;i<=n+1;i++)
        {
           if(s[i]-s[i-1]>max)
                max=s[i]-s[i-1];
        }
        left=max;//定区间端点
        right=l;
        while(right>=left)
        {
            mid=(left+right)/2;
            if(judge(mid))
            {
                c=mid;
                right=mid-1;
            }
            else
                left=mid+1;
        }
        printf("%d\n",c);
   }
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值