hdoj 4707 Pet 【并查集】

Pet

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2515    Accepted Submission(s): 1238


Problem Description
One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.
 

Input
The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.
 

Output
For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
 

Sample Input
  
  
1 10 2 0 1 0 2 0 3 1 4 1 5 2 6 3 7 4 8 6 9
 

Sample Output
  
  
2
 
这题运用技巧:(1)保留树的原始形状,即直接合并;(2)find()函数的递归形式,可以记录当前点到根节点的距离
代码:
#include<cstdio>
int per[100000+10];
int cnt;
void find(int x)
{
	if(per[x]!=x)
	{
		cnt++;	//递归,求当前点到根节点的路径长度 
		find(per[x]);
		return;
	}
 } 
 int main()
 {
 	int t,n,d,a,b;
 	scanf("%d",&t);
 	while(t--)
 	{
 		scanf("%d%d",&n,&d);
 		for(int i=0;i<n-1;i++)
 		{
 			scanf("%d%d",&a,&b);
 				per[b]=a;
		 }
		 int ans=0;
		 for(int i=0;i<n;i++)
		 {
		 	cnt=0;
		 	find(i);
		 	if(cnt>d)
		 		ans++;
		 }
		 printf("%d\n",ans);
	 }
	 return 0;
 }



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值