hdu-4707

Problem Description

One day, Lin Ji wake up in the morning and found that his pethamster escaped. He searched in the room but didn’t find the hamster. He tried to use some cheese to trap the hamster. He put the cheese trap in his room and waited for three days. Nothing but cockroaches was caught. He got the map of the school and foundthat there is no cyclic path and every location in the school can be reached from his room. The trap’s manual mention that the pet will always come back if it still in somewhere nearer than distance D. Your task is to help Lin Ji to find out how many possible locations the hamster may found given the map of the school. Assume that the hamster is still hiding in somewhere in the school and distance between each adjacent locations is always one distance unit.

Input

The input contains multiple test cases. Thefirst line is a positive integer T (0<T<=10), the number of test cases. For each test cases, the first line has two positive integer N (0<N<=100000) and D(0<D<N), separated by a single space. N is the number of locations in the school and D is the affective distance of the trap. The following N-1lines descripts the map, each has two integer x and y(0<=x,y<N), separated by a single space, meaning that x and y is adjacent in the map. Lin Ji’s room is always at location 0.

Output

For each test case, outputin a single line the number of possible locations in the school the hamster may be found.
一天早上小明醒来时发现他的宠物仓鼠不见了。 他在房间寻找但是没找到仓鼠。 他想用奶酪诱饵去找回仓鼠。 他把奶酪诱饵放在房间并且等待了好几天。 但是可怜的小明除了老鼠和蟑螂没见到任何东西。 他找到学校的地图发现地图上没有环路,并且学校里的每个站点都可以从他的房间到达。 奶酪诱饵的手册提到在距离D之内宠物必定会被吸引回来. 你的任务是帮助小明从给定的地图中有多少可能的站点是仓鼠的藏身处. 假定仓鼠一直藏在学校的某个站点并且两个相邻站点间的距离都是1个单位。
输入包含多组数据。 第一行一个整数T (0<T<=10), 表示测试数据的组数。 每组数据, 第一行包含两个整数 N (0<N<=100000) 和 D(0<D<N). N 是学校里的站点数, D 是诱饵的影响距离。 下面 N-1行为地图描述, 每行一对 x 和 y(0<=x,y<N), 用一个空格隔开, 表示x和y两个站点是相邻的。小明的房间用0表示。

Sample Input1

10 2
0 1
0 2
0 3
1 4
1 5
2 6
3 7
4 8
6 9

Sample Output

2

#include<queue>
#include<iostream>
#include<cstring>
#include<vector>
#include<stdio.h>
using namespace std;
int n,d;
const int N=1e6+6;
vector<int >v[N];
int dis[N];
int ans;
void bfs(int x)
{
    memset(dis,-1,sizeof(dis));
    queue<int > q;
    q.push(x);
    dis[x]=0;
    while(!q.empty())
    {
        int f=q.front();
        q.pop();
        if(dis[f]<=2)
        {
            ans++;
        }
        int it;
        for(int i=0;i<v[f].size();i++)
        {
            it=v[f][i];
            if(dis[it]==-1)
            {
                dis[it]=dis[f]+1;
                q.push(it);
            }
        }
    }    
}
int main()
{
    int t,a,b;
    scanf("%d",&t);
    while(t--)
    {
        for(int i = 0;i < n;i++)
               v[i].clear();
        scanf("%d%d",&n,&d);
        for(int i=1;i<n;i++)
        {
            scanf("%d%d",&a,&b);
            v[a].push_back(b);        //存表,双向 
            v[b].push_back(a);
        }
        ans=0;
        bfs(0);
        int poi=0;
         for(int i = 0;i < n;i++)
             if(dis[i] <= d&&dis[i]!=-1)
                 poi++;
    /*    for(int i=0;i<n;i++)
        {
            if(vis[i])
            num++;
        }
        ans=n-num;*/
        //printf("%d",)
        cout<<n-poi<<endl;
    }
    return 0;
}

输入输出最好都用scanf,printf
少用memset,虽然查找了一下,memset的时间复杂度应该是o(n),但在oj上可能是因为编译问题,用memset的话会tle,所以下次tle了可以考虑把memset换成for遍历,输入输出用scanf和printf。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值