poj 1985 Cow Marathon (树的直径 模板题)

Cow Marathon
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 5064 Accepted: 2464
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52

Hint

The longest marathon runs from farm 2 via roads 4, 1, 6 and  3 to farm 5 and is of length 20+3+13+9+7=52. 

做的第一道树的直径题目,记住模板,(1)链表储存图 【三步骤】1.结构体 2.表头初始化,top赋值0  3.加边函数  (2)输出构图  (3)两次bfs 分别寻找端点

大概形式是这样,模板要不能死记,但要记死!!

代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
#define MAXN 40000+10
#define MAXM 80000+10
using namespace std;

struct Edge//结构体,用于下面的链表储存图
{
    int to,val,next;
}edge[MAXM];
int dist[MAXN];//存储最长路
int vis[MAXN];
int head[MAXM],top;
int n,m;
int ans;
int node;
void init()//初始化
{
    top=0;
    memset(head,-1,sizeof(head));
}
void addedge(int u,int v,int w)//加边
{
    Edge E={v,w,head[u]};
    edge[top]=E;
    head[u]=top++;
}
void getmap()//构图
{
    int a,b,c;
    char s;
    for(int i=0;i<m;i++)
    {
        scanf("%d%d%d",&a,&b,&c);
        getchar();
        scanf("%c",&s);
        addedge(a,b,c);
        addedge(b,a,c);
    }
}
void bfs(int start)//两次搜索
{
    queue<int> q;
    memset(dist,0,sizeof(dist));
    memset(vis,0,sizeof(vis));
    node=start;
    vis[node]=1;
    q.push(node);
    while(!q.empty())
    {
        int u=q.front();
        q.pop();
        for(int i=head[u];i!=-1;i=edge[i].next)
        {
            Edge E=edge[i];
            if(!vis[E.to])
            {
                vis[E.to]=1;
                dist[E.to]=dist[u]+E.val;
                q.push(E.to);
            }
        }
    }
    ans=0;
    for(int i=1;i<=n;i++)
    {
        if(ans<dist[i])
        {
            ans=dist[i];
            node=i;
        }
    }
}
int main()
{
   while(~scanf("%d%d",&n,&m))
   {
       init();//千万别忘加
       getmap();
       bfs(1);
       bfs(node);
       printf("%d\n",ans);
   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值