poj 1958 Cow Marathon(树的直径,模板题)

Cow Marathon
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 5034 Accepted: 2452
Case Time Limit: 1000MS

Description

After hearing about the epidemic of obesity in the USA, Farmer John wants his cows to get more exercise, so he has committed to create a bovine marathon for his cows to run. The marathon route will include a pair of farms and a path comprised of a sequence of roads between them. Since FJ wants the cows to get as much exercise as possible he wants to find the two farms on his map that are the farthest apart from each other (distance being measured in terms of total length of road on the path between the two farms). Help him determine the distances between this farthest pair of farms. 

Input

* Lines 1.....: Same input format as "Navigation Nightmare".

Output

* Line 1: An integer giving the distance between the farthest pair of farms. 

Sample Input

7 6
1 6 13 E
6 3 9 E
3 5 7 S
4 1 3 N
2 4 20 W
4 7 2 S

Sample Output

52
//两次bfs求最长路   (模板题)
#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int maxn = 40010;
struct Edge{
    int to,val,next;
};
Edge edge[maxn * 2];
bool vis[maxn];
int head[maxn];
int edgenum;
int dist[maxn];
int ans,Tnode;
void init()
{
    memset(head,-1,sizeof(head));
    edgenum = 0;
}
void addEdge(int u,int v,int w)
{
    edge[edgenum].to = v;
    edge[edgenum].val = w;
    edge[edgenum].next = head[u];
    head[u] = edgenum++;
}
void BFS(int s)
{
    memset(vis,false,sizeof(vis));
    memset(dist,0,sizeof(dist));
    queue<int > q;
    q.push(s);
    ans = 0;
    dist[s] = 0;
    vis[s] = true;
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        for(int i = head[u] ; i != -1 ; i = edge[i].next)
        {
            int v = edge[i].to;
            if(!vis[v])
            {
                if(dist[v] < dist[u] + edge[i].val)
                    dist[v] = dist[u] + edge[i].val;
                vis[v] = true;
                q.push(v);
                if(ans < dist[v])
                {
                    ans = dist[v];
                    Tnode = v;
                }
            }
        }
    }
}
int main()
{
    int n,m,a,b,c;
    char ch[2];
    while(~scanf("%d%d",&n,&m))
    {
        init();
        for(int i = 0 ; i < m ; i++)
        {
            scanf("%d%d%d%s",&a,&b,&c,ch);
            addEdge(a,b,c);
            addEdge(b,a,c);
        }
        ans = 0;
        BFS(1);
        BFS(Tnode);
        printf("%d\n",ans);
    }
   return 0;
}

题目连接: poj 2631 Roads in the North http://poj.org/problem?id=2631 (模板题,可以先理解理解)
ac代码:
#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
using namespace std;
const int maxn = 10010;
struct Edge{
   int to,val,next;
};
Edge edge[maxn * 2];
bool vis[maxn];
int dist[maxn];
int ans,edgenum,tnode;
int head[maxn];
void init()
{
    memset(head,-1,sizeof(head));
    edgenum = 0;
}
void addEdge(int u,int v,int w)
{
    edge[edgenum].to = v;
    edge[edgenum].val = w;
    edge[edgenum].next = head[u];
    head[u] = edgenum++;
}
void BFS(int s)
{
    memset(vis,false,sizeof(vis));
    memset(dist,0,sizeof(dist));
    queue<int > q;
    q.push(s);
    vis[s] = true;
    dist[s] = 0;
    ans = 0;
    while(!q.empty())
    {
        int u = q.front();
        q.pop();
        for(int i = head[u] ; i != -1 ; i = edge[i].next)
        {
            int v = edge[i].to;
            if(!vis[v])
            {
                if(dist[v] < dist[u] + edge[i].val)
                    dist[v] = dist[u] + edge[i].val;
                q.push(v);
                vis[v] = true;
                if(ans < dist[v])
                {
                    ans = dist[v];
                    tnode = v;
                }
            }
        }
    }
}
int main()
{
    int u,v,w;
    init();
    while(scanf("%d%d%d",&u,&v,&w) != EOF)
    {
        addEdge(u,v,w);
        addEdge(v,u,w);
    }
    BFS(1);
    BFS(tnode);
    printf("%d\n",ans);
    return 0;
}

                
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值