hdoj 2647 Reward ( 拓扑排序--邻接表+队列 )

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7536    Accepted Submission(s): 2381


Problem Description
Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward will be at least 888 , because it's a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.
 

Output
For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.
 

Sample Input
  
  
2 1 1 2 2 2 1 2 2 1
 

Sample Output
  
  
1777 -1
 
每个人都有一个基本钱数888,要求  a 的钱数比b 大,(约束条件),数据大用邻接表。
备注:如果没有优先型,用一般队列就可以。

代码:

#include<cstdio>
#include<queue>
#include<cstring>
using namespace std;
int in[10010];
int money[10010];
struct Edge
{
	int to;
	int next;
}edge[20000+10];
int top,head[10000+10];
int n;
int topo()
{
//	priority_queue<int, vector<int>, greater<int> > q; 	//优先队列错误 
	queue<int> q;//适用一般队列 
	for(int i=1;i<=n;i++)
	{
		if(in[i]==0)
			q.push(i);
	}
	int ans=0,cnt=0,v;
	while(!q.empty())
	{
		//v=q.top();
		v=q.front;
		q.pop();
		in[v]--;
		ans+=money[v];
		cnt++;
		for(int i=head[v];i!=-1;i=edge[i].next)		
		{
			Edge E=edge[i];				
			in[E.to]--;			
			if(in[E.to]==0)
			{
				q.push(E.to);
				money[E.to]=money[v]+1;
			}
		}
	}
	if(cnt!=n)
		ans=-1;
	return ans;
}
int main()
{
	int m;
	int a,b;
	while(~scanf("%d%d",&n,&m))
	{
		memset(in,0,sizeof(in));
		memset(head,-1,sizeof(head));
		for(int i=1;i<=n;i++)
			money[i]=888;
		int sum;	
		for(int i=0;i<m;i++)
		{
			scanf("%d%d",&a,&b);
			edge[i].to=a;
			edge[i].next=head[b];
			head[b]=i;
			in[a]++;
		}
		sum=topo();
		printf("%d\n",sum);
	}
	return 0;
}
 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值