hdoj 1051 Wooden Sticks ( LIS_num )

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 18556    Accepted Submission(s): 7566


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
  
  
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
  
  
2 1 3
 题意:if l<=l' and w<=w'. 要裁木头,如果后一个木头的长度和重量都比上一个大,机器不需要重启动,相反就得重启动,问一共启动多少次

LIS:计算 最长递增子序列 的个数
和最少拦截系统基本一样,只是这个要比较两个变量,结构体比较。
然后就按上题的做法写
代码:
/*
和最少拦截系统基本一样,那题是比较一个变量,这题是比较两个变量 
*/

#include<cstdio>
#include<cstring>
#include<algorithm>
#define M 5000+10
using namespace std;
struct ST
{
	int l;
	int w;
};
ST a[M],b[M]; 
bool cmp(ST x,ST y)
{
	if(x.l==y.l)
	return x.w<y.w;
	else
	return x.l<y.l;
}
int LIS_num(int n)
{
	int cnt,flag;
	b[1].l=a[1].l; 
	b[1].w=a[1].w;
	cnt=1;
	for(int i=2;i<=n;i++)
	{
		flag=0;
		for(int j=1;j<=cnt;j++)
		{
			if(a[i].l>=b[j].l && a[i].w>=b[j].w)
			{
				flag=1;
				b[j].l=a[i].l;
				b[j].w=a[i].w;
				break;
			}			
		}
		if(flag==0)
		{
			cnt++;
			b[cnt].l=a[i].l;
			b[cnt].w=a[i].w;
		}
	}
	return cnt;
}
int main()
{
	int t,n;
	int i,j;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%d%d",&a[i].l,&a[i].w);		
		}
		sort(a+1,a+n+1,cmp);
		int ans=LIS_num(n);
		printf("%d\n",ans);
	}	
	return 0;
 } 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值