pog 2891 Strange Way to Express Integers (中国剩余定理 非互质)

Strange Way to Express Integers
Time Limit: 1000MS Memory Limit: 131072K
Total Submissions: 14789 Accepted: 4847

Description

Elina is reading a book written by Rujia Liu, which introduces a strange way to express non-negative integers. The way is described as following:

Choose k different positive integers a1a2…, ak. For some non-negative m, divide it by every ai (1 ≤ i ≤ k) to find the remainder ri. If a1a2, …, ak are properly chosen, m can be determined, then the pairs (airi) can be used to express m.

“It is easy to calculate the pairs from m, ” said Elina. “But how can I find m from the pairs?”

Since Elina is new to programming, this problem is too difficult for her. Can you help her?

Input

The input contains multiple test cases. Each test cases consists of some lines.

  • Line 1: Contains the integer k.
  • Lines 2 ~ k + 1: Each contains a pair of integers airi (1 ≤ i ≤ k).

Output

Output the non-negative integer m on a separate line for each test case. If there are multiple possible values, output the smallest one. If there are no possible values, output -1.

Sample Input

2
8 7
11 9

Sample Output

31

题解:题意就是线性方程组的解 x;

x = r1 (mod a1);

x = r2 (mod a2);

……

x = rn (mod an).

a1,a2……an,不两两互质的情况

两两合并求解

自己不能直接写下来,只能记模板,使用逆元还是有点不理解!

代码:

#include<cstdio>
#define LL __int64
LL gcd(LL a,LL b)
{
    if(b==0)
        return a;
    return gcd(b,a%b);
}
LL exgcd(LL a,LL b,LL &x,LL &y)
{
    if(b==0)
    {
        x=1;
        y=0;
        return a;
    }
    LL d,temp;
    d=exgcd(b,a%b,x,y);
    temp=x;
    x=y;
    y=temp-a/b*y;
    return d;
}
int main()
{
    LL k,a1,a2,r1,r2,c,d,x,y;
    while(~scanf("%I64d",&k))
    {
        int flag=0;
        scanf("%I64d%I64d",&a1,&r1);
        for(int i=0;i<k-1;i++)
        {
            scanf("%I64d%I64d",&a2,&r2);
            if(flag) continue;
            c=r2-r1;
            d=exgcd(a1,a2,x,y);
            if(c%d)
            {
                flag=1;
            }
            else
            {
                LL q=a2/d;
                x=(x*c/d%q+q)%q;//x的解可能是负数,
                r1=a1*x+r1;
                a1=a1*a2/d;//a1,a2的最小公倍数
            }

        }
        if(flag)
            printf("-1\n");
        else
            printf("%I64d\n",r1);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值