HDU 4034 Graph

Problem Description
Everyone knows how to calculate the shortest path in a directed graph. In fact, the opposite problem is also easy. Given the length of shortest path between each pair of vertexes, can you find the original graph?

Input
The first line is the test case number T (T ≤ 100).
First line of each case is an integer N (1 ≤ N ≤ 100), the number of vertexes.
Following N lines each contains N integers. All these integers are less than 1000000.
The jth integer of ith line is the shortest path from vertex i to j.
The ith element of ith line is always 0. Other elements are all positive.

Output
For each case, you should output “Case k: ” first, where k indicates the case number and counts from one. Then one integer, the minimum possible edge number in original graph. Output “impossible” if such graph doesn't exist.


Sample Input
3
3
0 1 1
1 0 1
1 1 0
3
0 1 3 
4 0 2
7 3 0
3
0 1 4
1 0 2
4 2 0
Sample Output
Case 1: 6
Case 2: 4
Case 3: impossible
Source

Recommend
lcy
题目大意:给定i~j的最短路径,让你求原始图中可能的最少边数。
思路:开始的时候不知道怎么去做尽管老师提示了用floyd去写,可是想到了除了枚举n外并没有想到好办法(但是枚举n不但可能会超时,而且,貌似这种方法是行不通的)!后来看了老师发的题解,又结合网上的资料,才算彻底把问题弄好,正解是 统计一下一条最短路由另外两条最短路构成的数量。然后用所有可能的边减去该数量即可!
code:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

const int N=105;
int t,tt,n;
int vis[N][N],mp[N][N];

int solve()
{
int i,j,k,m=0;
memset(vis,0,sizeof(vis));
for(k=0;k<n;k++)
for(i=0;i<n;i++)
for(j=0;j<n;j++)
if(i!=j&&i!=k&&k!=j)
{
//如果相等则说明ij的连线多余的
if(mp[i][j]==mp[i][k]+mp[k][j]&&!vis[i][j])
{
vis[i][j]=1;
m++;
}
//三角形第三边大于两边之和,形不成三角形,构不成图!
if(mp[i][j]>mp[i][k]+mp[k][j])
return -1;
}
return m;
}

int main()
{
scanf("%d",&t);
for (int ca=1;ca<=t;ca++)
{
printf("Case %d: ",ca);
int i,j;
scanf("%d",&n);
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&mp[i][j]);
int ans=solve();
if (ans==-1)
puts("impossible");
else
printf("%d\n",n*(n-1)-ans);
}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值