pojCuring 2.0(dfs)

Curling 2.0
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 15534 Accepted: 6420

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board 
First row of the board
 
... 
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6 
1 0 0 2 1 0 
1 1 0 0 0 0 
0 0 0 0 0 3 
0 0 0 0 0 0 
1 0 0 0 0 1 
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1
AC代码:
//poj3009 dfs+剪枝 
//题目大意:冰球游戏;目的是将冰球从起点推到终点;问最少需要推多少次?
//每次推一下冰球,冰球会一直径直向前;直到碰到石块;且碰到的石块会消失;
//解题思路:这里就用dfs解决;不过需要减一下枝; 即当推得次数大于10时;就返回输出-1;
//其他就是从起点开始搜索;思路都懂;问题就是实现的时候;这里需要两个循环;当冰球未遇到
//冰球时;就一直循环到头,直到遇到石块或出界;当遇到石块时停下,记一次数;向下一个方向继续搜索;
//还有需要注意的就是判断石块是从停下的位置走好几步才遇到石块还是在停下的位置旁边的石块;如果是前者;
//就可以计数并将1改为0;退回来继续搜索,如果否,就不能; 
#include<stdio.h>
#include<string.h>
#include<math.h>
#define INF 0x3f3f3f
int map[100][100];
int dx[4]={0,-1,0,1};
int dy[4]={1,0,-1,0};
int n,m,cnt,gx,gy,ans,sx,sy,flag;
bool jude(int x,int y)
{
	if(x<0||x>=m||y<0||y>=n||map[x][y]==1)
	 return false;
	return true;
}
void dfs(int x,int y)
{
	int i,fx,fy;
	if(cnt>10) return;   //剪枝 
	for(i=0;i<4;i++)
	{
		flag=0;
		fx=x+dx[i];fy=y+dy[i];
     	while(jude(fx,fy))
     	{
     	   flag=1;
     	   if(fx==gx&&fy==gy)
     	   {
     	     if(ans>cnt) ans=cnt;
			 return ;	
		   }
		 fx+=dx[i];fy+=dy[i];
		}
		if(map[fx][fy]==1&&flag)  //防止map[fx][fy]=1,但距离上一个点只差一步的情况; 
		{
			cnt++;
			map[fx][fy]=0;
			dfs(fx-dx[i],fy-dy[i]);
			map[fx][fy]=1;           //回溯的将0改为1;计数也回到上一步; 
			cnt--;
		}
	}   	
}
int main()
{
   int i,j,k;
   while(scanf("%d%d",&n,&m)&&(n|m))
   {
   	memset(map,0,sizeof(map)); 
      	for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			{
				scanf("%d",&map[i][j]);
				if(map[i][j]==2)
			    {
			    	sx=i;sy=j;
				}
				if(map[i][j]==3)
				{
					gx=i;gy=j; 
				} 
			}
		 } 
		 ans=INF;cnt=1;
		 dfs(sx,sy);
		 if(ans!=INF)
		  printf("%d\n",ans);
		else
		 printf("-1\n");
   }
   return 0;	
} 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

bokzmm

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值