寒假训练营第二天(初识C++):B题

补题中。。。

B - B POJ - 3096

The D-pairs of a string of letters are the ordered pairs of letters that are distance D from each other. A string is D-unique if all of its D-pairs are different. A string is surprising if it is D-unique for every possible distance D.

Consider the string ZGBG. Its 0-pairs are ZG, GB, and BG. Since these three pairs are all different, ZGBG is 0-unique. Similarly, the 1-pairs of ZGBG are ZB and GG, and since these two pairs are different, ZGBG is 1-unique. Finally, the only 2-pair of ZGBG is ZG, so ZGBG is 2-unique. Thus ZGBG is surprising. (Note that the fact that ZG is both a 0-pair and a 2-pair of ZGBG is irrelevant, because 0 and 2 are different distances.)

Acknowledgement: This problem is inspired by the “Puzzling Adventures” column in the December 2003 issue of Scientific American.


Input


The input consists of one or more nonempty strings of at most 79 uppercase letters, each string on a line by itself, followed by a line containing only an asterisk that signals the end of the input.


Output


For each string of letters, output whether or not it is surprising using the exact output format shown below.


Sample Input


ZGBG
X
EE
AAB
AABA
AABB
BCBABCC
*


Sample Output


ZGBG is surprising.
X is surprising.
EE is surprising.
AAB is surprising.
AABA is surprising.
AABB is NOT surprising.
BCBABCC is NOT surprising.

题意:又是一道令人头疼的英文题,这题就是讲判断一个字符串是否surprising,surprising的条件是:选择若干对字符串,每对字符串由两个字符构成,首先是每个字符距离为零,然后是二,依此选择,判断选取不同距离时,有没有出现相同的字符串,若出现则NOT surprising,若取所有不同距离都没有相同字符串,则surprising。
由于每个字符串都是由两个字符构成,刚好我们前几天学了STL入门,于是我就想到了运用pair和map求解。

AC代码如下:

#include<iostream>
#include<map>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
    map<pair<char,char>,int>p;
    pair<char,char>q;
    char a[100];
    while(scanf("%s",a)&&strcmp(a,"*"))
    {
        int len=strlen(a);
        int i,j,flag=0;
        for(j=1;j<len;j++)
        {
            p.clear();
            for(i=0;i<len-j;i++)
            {
                q=make_pair(a[i],a[i+j]);
                p[q]++;
            }
            for(i=0;i<len;i++)
            {
                q=make_pair(a[i],a[i+j]);
                if(p[q]>=2)
                {
                    flag=1;
                    break;
                }
            }
            if(flag==1)
            {
                printf("%s is NOT surprising.\n",a);
                break;
            }
        }
        if(flag==0)
            printf("%s is surprising.\n",a);
    }
    return 0;
}

小白心得

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值