寒假训练营第八天(二分与分治):E题:快速幂

E - 快速幂 POJ - 1995

People are different. Some secretly read magazines full of interesting girls’ pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players’ experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.


Input


The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.


Output


For each assingnement there is the only one line of output. On this line, there is a number, the result of expression
(A1B1+A2B2+ … +AHBH)mod M.


Sample Input


3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132


Sample Output


2
13195
13

题解
这道虽然是英文题,但是应该还好懂,因为救我这英文菜鸟都看懂了,所以对于大家来说肯定不难。主要就是说给你几组数据,每组数据包括一个余数m,一个数据组数,紧接着就是n组数据:首先是底数,其次是幂,要你求各组数据的幂之和然后除以m。

在开始自己学习了快速幂的相关知识后就开始做这道题,首先肯定是二话不说直接就准备暴力解决,结果在过样例时发现与样例输出不同,于是就开始调试,发现由于数值过大,就是是long long型也不可以,于是就想起来第二种方法取余,于是就在网上搜索具体是什么意思,于是发现了一个同余定理:(a+b)%m=(a%m+b%m)%m;了解了快速幂取模。通过这样减小数值。

于是AC代码如下:

/**由于测试的数过大采用把整形改为long long无效
于是采用取余   快速幂取模*/

#include<iostream>
#include<cstdio>
#include<cstdio>
using namespace std;
int main()
{
    int  n;
    scanf("%d",&n);
    while(n--)
    {
        int z;
        long long int m,sum=0;
        scanf("%lld",&m);
        scanf("%d",&z);
        while(z--)
        {
            long long int a,b;
            scanf("%lld %lld",&a,&b);
            long long int r=1;
            a=a%m;
            while(b!=0)
            {
                if(b%2)
                {
                    r=(r*a)%m;
                }
                a=(a*a)%m;
                b/=2;
            }
            sum+=r;
        }
        long long int answer=sum%m;
        printf("%lld\n",answer);
    }
    return 0;
}

小白心得
肝不动了,不然明天就起不来了

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值