hdu 2988:Dark roads(kruskal算法构建最小生成树应用)

hdu 2988:Dark roads(kruskal算法构建最小生成树应用)


Problem Description


Economic times these days are tough, even in Byteland. To reduce the operating costs, the government of Byteland has decided to optimize the road lighting. Till now every road was illuminated all night long, which costs 1 Bytelandian Dollar per meter and day. To save money, they decided to no longer illuminate every road, but to switch off the road lighting of some streets. To make sure that the inhabitants of Byteland still feel safe, they want to optimize the lighting in such a way, that after darkening some streets at night, there will still be at least one illuminated path from every junction in Byteland to every other junction.

What is the maximum daily amount of money the government of Byteland can save, without making their inhabitants feel unsafe?


Input


The input file contains several test cases. Each test case starts with two numbers m and n, the number of junctions in Byteland and the number of roads in Byteland, respectively. Input is terminated by m=n=0. Otherwise, 1 ≤ m ≤ 200000 and m-1 ≤ n ≤ 200000. Then follow n integer triples x, y, z specifying that there will be a bidirectional road between x and y with length z meters (0 ≤ x, y < m and x ≠ y). The graph specified by each test case is connected. The total length of all roads in each test case is less than 231.


Output


For each test case print one line containing the maximum daily amount the government can save.


Sample Input


7 11
0 1 7
0 3 5
1 2 8
1 3 9
1 4 7
2 4 5
3 4 15
3 5 6
4 5 8
4 6 9
5 6 11
0 0


Sample Output


51

这道题还是比较简单,但是为了更好的复习下kruskal算法,于是还是打算写篇博客;
理解题意后发现就是构建最小生成树,显然这里用kruskal算法较好

至于kruskal算法原理,请看这篇博客:传送门

具体见代码:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=200010;
typedef struct
{
    int v1,v2;
    int value;
}EdgeType;
EdgeType edges[maxn],tree[maxn];     //分别表示图和最小生成树树结构
int father[maxn];       //存放祖先结点
int n,m;         //分别表示结点数目与边的梳棉机
int sum;        //权值和

int cmp(EdgeType a,EdgeType b)
{
    return a.value<b.value;
}
/**通过递归获得祖先结点*/
int Find(int a)
{
    if(father[a]!=a)
        father[a]=Find(father[a]);
    return father[a];
}
void kruskal()
{
    /**对father数组初始化*/
    for(int i=0;i<n;i++)
        father[i]=i;
    for(int i=0;i<m;i++)
    {
        int vf1=Find(edges[i].v1);
        int vf2=Find(edges[i].v2);
        if(vf1!=vf2)
        {
            father[vf2]=vf1;
            sum-=edges[i].value;     //sum减去权值
        }
    }
}
int main()
{
    while(~scanf("%d%d",&n,&m))
    {
        if(n==0&&m==0)
            break;
        memset(tree,0,sizeof(tree));

        sum=0;      //归零
        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&edges[i].v1,&edges[i].v2,&edges[i].value);
            sum+=edges[i].value;      //sum加上权值
        }

        /**根据kruskal算法原理知,先对所有边由权值从小到大排序*/

        sort(edges,edges+m,cmp);

        kruskal();

        printf("%d\n",sum);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值