10189. Minesweeper - UVA

?题目描述

Have you ever played Minesweeper? It's a cute little game which comes within a certain Operating System which name we can't really remember. Well, the goal of the game is to find where are all the mines within a MxN field. To help you, the game shows a number in a square which tells you how many mines there are adjacent to that square. For instance, supose the following 4x4 field with 2 mines (which are represented by an * character):

*...
....
.*..
....
If we would represent the same field placing the hint numbers described above, we would end up with:

*100
2210
1*10
1110
As you may have already noticed, each square may have at most 8 adjacent squares.

Input
The input will consist of an arbitrary number of fields. The first line of each field contains two integers n and m (0 < n,m <= 100) which stands for the number of lines and columns of the field respectively. The next n lines contains exactly m characters and represent the field. Each safe square is represented by an "." character (without the quotes) and each mine square is represented by an "*" character (also without the quotes). The first field line where n = m = 0 represents the end of input and should not be processed.

Output
For each field, you must print the following message in a line alone:

Field #x:
Where x stands for the number of the field (starting from 1). The next n lines should contain the field with the "." characters replaced by the number of adjacent mines to that square. There must be an empty line between field outputs.

Sample Input
4 4
*...
....
.*..
....
3 5
**...
.....
.*...
0 0
Sample Output
Field #1:
*100
2210
1*10
1110

Field #2:
**100
33200
1*100

 

? Method : 

//
// Created by wqxsh on 2019/2/2.
//

#include<bits/stdc++.h>
using namespace std;

const int dX[]={-1,-1,-1,0,0,+1,+1,+1};
const int dY[]={-1,0,+1,-1,+1,-1,0,+1};
char mines[102][102];
int row, col;

bool boundary(int x,int y){
    if (x < 0 || y < 0 || x >= row || y >= col) return false;
    else { return true; }
}

int solve(int m, int n){
    int cnt = 0;
    for (int i = 0; i < 8; ++i) {
        // 对8个邻居方块进行判断
        if (boundary(m+dX[i],n+dY[i])&& mines[m+dX[i]][n+dY[i]]=='*') {
            ++cnt;
        }
    }
    return cnt;
}


int main(){
//    freopen("in.txt", "r", stdin);
//    freopen("out.txt", "w", stdout);
    int kcase=1;
    while (cin >> row >> col && row && col) {
        if (kcase != 1) { cout << endl; } //为了防止last的case输出回车,所以在初始化第二个case之前提前回车
        for (int i = 0; i < row; ++i) {
            for (int j = 0; j < col; ++j) {
                cin >> mines[i][j];
            }
        }
        cout << "Field #" << kcase++ << ':' << endl;
        for (int i = 0; i < row; ++i) {
            for (int j = 0; j < col; ++j) {
                if (mines[i][j] == '*')
                    cout << '*';
                else cout << solve(i, j); //若不是雷,输出周围8个邻居中mine的个数
            }
            cout << endl;
        }
    }
    return 0;
}





 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值