centOS 7 自带python2.7 无法使用pip命令 问题解决

原创 2018年04月17日 08:35:24

1.首先检查linux有没有安装python-pip包,直接执行 yum install python-pip

提示:Cannot find a valid baseurl for repo: base/7/x86_64

(这里,我的服务器无法连上网,需要配置dns,vi /etc/resolv.conf , 后面增加 servername 8.8.8.8 第二行 servername 4.4.4.4)

2.提示:没有可用软件包 python-pip。就执行命令 yum -y install epel-release 。然后再执行 yum install python-pip

3.对安装好的pip进行升级 pip install --upgrade pip


python 2.7.14版本的requests库的安装

python 2.7.14是自带pip和easy_install的,我是使用pip安装requests库 1,找到自己安装python的目录,找到里面的一个Scripts,复制路径,作...
  • jjarchu
  • jjarchu
  • 2017-12-05 01:52:35
  • 784

CentOS7自带的python3下如何使用python3的pip

虽说python3已经存在多年,可服务器系统组件多数还都是python2的。因此在CentOS7下,使用python3就要另外安装。 CentOS7自带了python3.4,yum install就...
  • 21bird
  • 21bird
  • 2018-01-09 16:20:43
  • 359

python2.7无法使用pip(安装easy_install)

1. 在Python IDLE下,我们输入以下代码   from urllib import urlopen【回车】   data = urlopen('http://peak.telecom...
  • sinat_34603016
  • sinat_34603016
  • 2017-04-21 21:05:14
  • 1496

CentOS7 下 python2.7.5 安装 pip 后再安装 requests包

CentOS7 下 python2.7.5 安装 pip 后再安装 requests包
  • trb331617
  • trb331617
  • 2017-06-03 15:01:23
  • 2283

centos7 安装 python3 pip3不能使用问题

终于可以输出一点经验了。。 总结了其他人的经验,经过自己尝试成功了 分享给大家做参考 os: centos 7 #安装gcc,否则在./configure时会e...
  • unxeer
  • unxeer
  • 2017-04-20 15:17:11
  • 1926

pip命令无法使用

今天在学习Python时需要安装Requests    使用命令:pip install requests       提示错误       我的解决办法是:       cmd 切换到Pytho...
  • CuiXiaoBo521
  • CuiXiaoBo521
  • 2017-07-09 22:26:31
  • 2621

CentOS6.5上安装Python2.7和PIP

目前大部分用户使用的CentOS6.5上默认的Python还是2.6版本。升级到Python2.7碰到很多问题。本文将介绍如何安装Python2.7。 1. 安装必要的准备包         安装...
  • CNHK1225
  • CNHK1225
  • 2016-09-25 20:14:12
  • 1374

centos安装python2.7和pip2.7

安装python2.7yum groupinstall -y "Development tools"yum -y install gcc gcc-c++ make zlib-devel pcre-de...
  • zhaomeng1123
  • zhaomeng1123
  • 2016-06-27 18:47:03
  • 4495

【编程语言】CentOS 7 下pip更新命令

CentOS 7 下pip更新命令 CentOS 7 需要更新pip时,只需要一下简单的命令即可搞定: pip install --upgrade pip...
  • j790675692
  • j790675692
  • 2017-06-05 17:56:11
  • 1366

centos安装python2.7,easy_install,pip

python2.7安装参考 :http://www.cnblogs.com/dudu/p/4294238.html下面安装pip step1:安装setuptoolswget https://boo...
  • u014087707
  • u014087707
  • 2016-07-03 01:41:33
  • 558
收藏助手
不良信息举报
您举报文章:centOS 7 自带python2.7 无法使用pip命令 问题解决
举报原因:
原因补充:

(最多只允许输入30个字)