POJ 2965

与poj 1753解法差不多  有所不同的是本题改变的是选定棋子所在的整行整列,并且需要输出改动的路径,改动路径通过标记数组状态即可输出。做法同样是对选定一个、两个至十六个棋子用dfs进行枚举.

The Pilots Brothers' refrigerator
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24138 Accepted: 9333 Special Judge

Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

Source

Northeastern Europe 2004, Western Subregion
#include<stdio.h>
#include<string.h>
int flag;
int  arr[20][20];
bool vis[20][20];
int find(int x,int y)
{
    for(int i=1; i<=4; i++)
    {
        for(int j=1; j<=4; j++)
            if(arr[i][j]!=0)
                return 0;
    }
    return 1;
}
void change(int x,int y)
{
    for(int i=0;i<=4;i++)
    {
        arr[x][i]=!arr[x][i];
    }
    for(int i=0;i<=4;i++)
    {
        arr[i][y]=!arr[i][y];
    }
    arr[x][y]=!arr[x][y];
}
void f(int x,int y,int step,int n)//深搜
{
    if(step==n)
    {
        if(find(x,y))
            flag=1;
        return ;
    }
    if(flag||x==5)return ;
    change(x,y);
    vis[x][y]=!vis[x][y];
    if(y<4)
        f(x,y+1,step+1,n);
    else
        f(x+1,1,step+1,n);
        if(flag)
            return ;
    change(x,y);
    vis[x][y]=!vis[x][y];
    if(y<4)
        f(x,y+1,step,n);
    else
        f(x+1,1,step,n);
    return ;
}
int main()
{

      flag=0;
    char c;
    memset(arr,0,sizeof(arr));
    memset(vis,false,sizeof(vis));
    for(int i=1; i<=4; i++)
    {
        for(int j=1; j<=4; j++)
        {
            scanf("%c",&c);
            if(c=='+')
                arr[i][j]=1;
        }
        getchar();
    }
    for(int i=0; i<=16; i++)
    {
        f(1,1,0,i);
        if(flag)
        {
            printf("%d\n",i);
            for(int i=1;i<=4;i++)
            {
                for(int j=1;j<=4;j++)
                    if(vis[i][j])
                    printf("%d %d\n",i,j);
            }
            break;
        }
    }
    if(!flag)
        printf("Impossible\n");


    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值