E、Palindrome

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome.

As an example, by inserting 2 characters, the string “Ab3bd” can be transformed into a palindrome (“dAb3bAd” or “Adb3bdA”). However, inserting fewer than 2 characters does not produce a palindrome.

Input
Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A’ to ‘Z’, lowercase letters from ‘a’ to ‘z’ and digits from ‘0’ to ‘9’. Uppercase and lowercase letters are to be considered distinct.

Output
Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input
5
Ab3bd

Sample Output
2

题目大意:将一串字符串变成回文串至少需要插入几个字符

必备知识:
1、最长公共子序列:参考博客:动态规划 最长公共子序列 过程图解
2、滚动数组(使用二维数组dp[5000][5000]会爆内存) 参考博客:滚动数组的简单实用

这题就是求 原串长度 - 原串和逆序串的最长公共子序列

#include <stdio.h>
#include <string.h>

void copy(char str1[],char str2[],int len)
{
    for (int i = 0; i < len; i++)
    {
        str2[len-i-1] = str1[i];
    }
    str2[len] = '\0';
}

int max(int x,int y)
{
    return x > y ? x : y;
}

int main()
{
    int n;
    char str1[5005];
    char str2[5005];
    int dp[2][5005];

    scanf("%d",&n);
    scanf("%s",str1);

    copy(str1,str2,n);
    memset(dp,0,sizeof(dp));

    int flag = 1;
    for (int i = 1; i <= n; i++)
    {
        flag = 1-flag;
        for (int j = 1; j <= n; j++)
        {
            if (str1[i-1] == str2[j-1]) dp[flag][j] = dp[1-flag][j-1] + 1;
            else dp[flag][j] = max(dp[flag][j-1],dp[1-flag][j]);
        }
    }

    printf("%d\n",n-dp[flag][n]);

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值