NYOJ VF

VF

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 2
描述
Vasya is the beginning mathematician. He decided to make an important contribution to the science and to become famous all over the world. But how can he do that if the most interesting facts such as Pythagor’s theorem are already proved? Correct! He is to think out something his own, original. So he thought out the Theory of Vasya’s Functions. Vasya’s Functions (VF) are rather simple: the value of the  N th VF in the point  S is an amount of integers from 1 to  N that have the sum of digits  S. You seem to be great programmers, so Vasya gave you a task to find the milliard VF value (i.e. the VF with  N = 10 9) because Vasya himself won’t cope with the task. Can you solve the problem?
输入
There are multiple test cases.
Integer S (1 ≤ S ≤ 81).
输出
The milliard VF value in the point S.
样例输入
1
样例输出
10


本题的意思是:求出1~1000000000之间的各个数字之和等于s的值的个数。

当s=1:只有1,10,100,1000,10000,100000,1000000,10000000,100000000,1000000000一共10个;

当s>=2:当是一位数-->2; 当时2位数 -->11,20两个 ;当时3位数-->110,101,200,三个;...............

所以说要求出等于s值得个数,需要求出1 ~ 9每位位数的个数相加;

dp[i][j] 表示 i 位数的值等于 j 的个数;


i=1、只有一位的数字,因为s>=1,所以最低位只能是1-9 其中的一个数字。

i>1、假设第i位放数字k(则k只能是0~9并且k<=s),若要使第前i位数字之和为j,那么前i-1位只能放j-k,由此得出动态转移方程:d[i]][j]=d[i][j]+d[i-1][j-k] (0<=k<=j&&k<=9)。



#include<cstdio>
#include<iostream>
using namespace std;
int dp[10][82];
int main()
{
    for(int i = 1; i<10;i++)dp[1][i] = 1; 
for(int i = 1; i<= 9; i++){
   for(int j=1; j <= 9*i ; j++){
    for(int k = 0; k<=9 && k<=j;k++){
    dp[i][j] += dp[i-1][j-k];
}
}


    int n;
    while(scanf("%d",&n)!=EOF){
    int ans=0;
    if(n==1)printf("10\n");
    else {
    for(int i=1; i< 10; i++){
    ans += dp[i][n];
}
    printf("%d\n",ans);
}
     }
     return 0;

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值