POJ 1163 The Triangle

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)

Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally( 对角线地 ) down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Thinking :
#include<cstdio>
#include<vector>
#include<iostream>
#include<cstring>
using namespace std;

vector<int> v1, v2;
int N;
const int maxn = 100+5;
int maxx = -100000; //最长路径长度
int m[maxn][maxn]; //输入每个节点值
int dp[maxn][maxn]; //每个节点到顶点的最大值

int max(int i, int j){
    return i>j?i:j;
}

int maxtotal(int i, int j){
    if(i == N) return 0;
    if(dp[i][j] >= 0) return dp[i][j];
    return dp[i][j] = m[i][j] + max(maxtotal(i+1, j), maxtotal(i+1, j+1));
}

int main(){
    scanf("%d", &N);
    memset(dp, -1, sizeof(dp));
    for(int i = 0; i < N; i++)
        for(int j = 0; j <= i; j++)
            scanf("%d", &m[i][j]);
    printf("%d", maxtotal(0, 0));
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值