POJ 3262

Protecting the Flowers

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8037 Accepted: 3247

Description

Farmer John went to cut some wood and left N (2 ≤ N ≤ 100,000) cows eating the grass, as usual. When he returned, he found to his horror that the cluster of cows was in his garden eating his beautiful flowers. Wanting to minimize the subsequent damage, FJ decided to take immediate action and transport each cow back to its own barn.

Each cow i is at a location that is Ti minutes (1 ≤ Ti ≤ 2,000,000) away from its own barn. Furthermore, while waiting for transport, she destroys Di (1 ≤ Di ≤ 100) flowers per minute. No matter how hard he tries, FJ can only transport one cow at a time back to her barn. Moving cow i to its barn requires 2 × Ti minutes (Ti to get there and Ti to return). FJ starts at the flower patch, transports the cow to its barn, and then walks back to the flowers, taking no extra time to get to the next cow that needs transport.

Write a program to determine the order in which FJ should pick up the cows so that the total number of flowers destroyed is minimized.

Input

Line 1: A single integer N
Lines 2..N+1: Each line contains two space-separated integers, Ti and Di, that describe a single cow’s characteristics

Output

Line 1: A single integer that is the minimum number of destroyed flowers

Sample Input

6
3 1
2 5
2 3
3 2
4 1
1 6

Sample Output

86

Thinking: 这回贪心假设有两头牛(a, b) , (x, y)(T为这两头牛被赶之前的时间)

(a, b)先的话被吃的草为 Tb + (T + a)y ①
(x, y)先的话被吃的草为 Ty + (T + x)b ②
① - ② 得到 ay - xb
排序按 ay < xb 取值即可

#include<cstdio>
#include<algorithm>
using namespace std;

int N;
const int maxn = 100005;
struct node {
    int T, D;
    bool operator < (const node& n) const {
        return T*n.D < n.T*D;
    }
}cows[maxn];

void solve() {
    sort(cows, cows + N);
    long long res = 0;
    for (int i = 0; i < N; i++)
        res += (long long)cows[i].D;
    long long ans = 0;
    for (int i = 0; i < N; i++) {
        res -= (long long)cows[i].D;
        ans += res * cows[i].T * 2;
    }
    printf("%lld\n", ans);
}

int main() {
    scanf("%d", &N);
    for (int i = 0; i < N; i++)
        scanf("%d%d", &cows[i].T, &cows[i].D);
    solve();
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值