National Treasures 6.3.8

National Treasures

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 118    Accepted Submission(s): 60

 
Problem Description
The great hall of the national museum has been robbed few times recently. Everyone is now worried about the security of the treasures on display. To help secure the hall, the museum contracted with a private security company to provide additional guards to stay in the great hall and keep an eye on the ancient artifacts. The museum would like to hire the minimum number of additional guards so that the great hall is secured.
The great hall is represented as a two dimensional grid of R × C cells. Some cells are already occupied with the museum’s guards. All remaining cells are occupied by artifacts of different types (statues, sculptures, . . . etc.) which can be replaced by new hired guards. For each artifact, few other cells in the hall are identified as critical points of the artifact depending on the artifact value, type of vault it is kept inside, and few other factors. In other words, if this artifact is going to stay in the hall then all of its critical points must have guards standing on them. A guard standing in a critical position of multiple artifacts can keep an eye on them all. A guard, however,
can not stand in a cell which contains an artifact (instead, you may remove the artifact to allow the guard to stay there). Also you can not remove an artifact and leave the space free (you can only replace an artifact with a new hired guard).
Surveying all the artifacts in the great hall you figured out that the critical points of any artifact (marked by a ) are always a subset of the 12 neighboring cells as shown in the grid below.



Accordingly, the type of an artifact can be specified as a non-negative integer where the i-th bit is 1 only if critical point number i from the picture above is a critical point of that artifact. For example an artifact of type 595 (in binary 1001010011) can be pictured as shown in the figure below. Note that bits are numbered from right to left (the right-most bit is bit number 1.) If a critical point of an artifact lies outside the hall grid then it is considered secure.



You are given the layout of the great hall and are asked to find the minimum number of additional guards to hire such that all remaining artifacts are secured.
Input
Your program will be tested on one or more test cases. Each test case is specified using R+1 lines.
The first line specifies two integers (1<= R,C <= 50) which are the dimensions of the museum hall. The next R lines contain C integers separated by one or more spaces. The j-th integer of the i-th row is -1 if cell (i, j) already contains one of the museum’s guards, otherwise it contains an integer (0 <= T <= 2 12) representing the type of the artifact in that cell.
The last line of the input file has two zeros.
Output

            For each test case, print the following line:
k. G
Where k is the test case number (starting at one,) and G is the minimum number of additional guards to hire such that all remaining artifacts are secured.
Sample Input
1 3
512 -1 2048
2 3
512 2560 2048
512 2560 2048
0 0
Sample Output
1. 0
2. 2
 
题意是保证宝藏(i, j)的周围12个点有守卫。
可以看到宝藏i+j 与周围12个点的奇偶性是不用的,因此以i+j奇偶性二分。
 
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;

const int MAXN = 2500 + 10;
vector<int> G[MAXN];
int link[MAXN], done[MAXN], g[MAXN];
int r, c;
int dir[12][2] = {{-1, -2}, {-2, -1}, {-2, 1}, {-1, 2}, 
					{1, 2}, {2, 1}, {2, -1}, {1, -2}, {-1, 0}, {0, 1}, {1, 0}, {0, -1}};	//12个方向 
bool find_match(int i){
	for(int j = 0; j < G[i].size(); j++){
		int to = G[i][j];
		if(!done[to]){
			done[to] = 1;
			if(link[to] == -1 || find_match(link[to])){
				link[to] = i;
				return true;
			}
		}
	}
	return false;
}
int main(){
	int kase = 1;
	while(scanf("%d%d", &r, &c) && (r || c)){
		memset(G, 0, sizeof(G));
		memset(g, 0, sizeof(g));
		for(int i = 0; i < r; i++){
			for(int j = 0; j < c; j++){
				scanf("%d", &g[i*c + j]);
			}
		}
		for(int i = 0; i < r; i++){
			for(int j = 0; j < c; j++){
				if(g[i*c + j] == -1) continue;
				for(int k = 0; k < 12; k++){
					if(g[i*c + j] & (1 << k)){
						int nx = i + dir[k][0];
						int ny = j + dir[k][1];
						if(nx < 0 || nx >= r || ny < 0 || ny >= c || g[nx*c + ny] == -1) continue;
						if((i+j)%2) G[i * c + j].push_back(nx * c + ny);
						else G[nx * c + ny].push_back(i * c + j); 
					}
				}
			}
		}
		int cnt = 0;
		memset(link, -1, sizeof(link));
		for(int i = 0; i < r * c; i++){
			memset(done, 0, sizeof(done));
			if(find_match(i)) cnt++;
		}
		printf("%d. %d\n", kase++, cnt);
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值