hdu - 4336 Card Collector

Problem Description

In your childhood, do you crazy for collecting the beautiful cards in the snacks? They said that, for example, if you collect all the 108 people in the famous novel Water Margin, you will win an amazing award.

As a smart boy, you notice that to win the award, you must buy much more snacks than it seems to be. To convince your friends not to waste money any more, you should find the expected number of snacks one should buy to collect a full suit of cards.

Input

The first line of each test case contains one integer N (1 <= N <= 20), indicating the number of different cards you need the collect. The second line contains N numbers p1, p2, ..., pN, (p1 + p2 + ... + pN <= 1), indicating the possibility of each card to appear in a bag of snacks.

Note there is at most one card in a bag of snacks. And it is possible that there is nothing in the bag.

Output

Output one number for each test case, indicating the expected number of bags to buy to collect all the N different cards.

You will get accepted if the difference between your answer and the standard answer is no more that 10^-4.

Sample Input

1

0.1

2

0.1 0.4

Sample Output

10.000

10.500

思路:

概率dp。

用状态压缩来表示每一种状态。

dp[i]表示状态为i时还需要拿卡的次数期望。用二进制表示每一个卡是否拿到,比如二进制11表示第一张和第二张卡已经拿到。

dp[1<<n - 1]表示全部的卡都已经拿到了,因此这个是已知为零。

当处于dp[i]时,它下一步有几种可能:

1:没拿到卡,概率为p1

2:拿到的卡已存在,概率和为p2

3:拿到的卡不存在,这时要根据每一种概率计算出期望的次数,然后再加上需要拿的那一次的次数。设这个期望次数为a。

则:dp[i] = a / (1 - p1 - p2)。

最后得出dp[0]为答案。

#include<stdio.h>
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;

const int MAXN = 22;
double p[MAXN];
double dp[1<<MAXN];

int main()
{
    int n;
    while (scanf("%d", &n) != EOF)
    {
        double t = 0;
        for (int i = 0; i < n; i++)
        {
            scanf("%lf", &p[i]);
            t += p[i];
        }
        t = 1 - t;
        dp[(1<<n) - 1] = 0;
        for (int i = (1<<n) - 2; i >= 0; i--)
        {
            double x = t;
			double sum = 1;
            for (int j = 0; j < n; j++)
            {
                if (i & (1<<j))
				{
					x += p[j];
				}
                else
				{
					sum += p[j] * dp[i|(1<<j)];
				}
            }
            dp[i] = sum / (1 - x);
        }
        printf("%.5lf\n", dp[0]);
    }

    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值