【题解】POJ 3050 Hopscotch(搜索)

POJ 3050 Hopscotch


原题

https://vjudge.net/problem/POJ-3050

The cows play the child’s game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.
They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).
With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).
Determine the count of the number of distinct integers that can be created in this manner.

Input
Lines 1…5: The grid, five integers per line
Output
Line 1: The number of distinct integers that can be constructed

Sample Input

1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1

Sample Output

15

题解

题意:以任意一个点为起点,走五步即路径为一个六位数,问有多少种不重复的六位数。
输入:5行5列的整数。输出:一个整数。
思路:遍历每一个点,每个点都深搜一遍,走完五步return,用set来去重。

#include<iostream>
#include<set>

using namespace std;

int mp[6][6];	//用来存输入
set <int> se;	//用来去重
int dt[][2]= {1, 0, -1, 0, 0, 1, 0, -1};//方向
void dfs(int x, int y, int step, int num) {//x,y为坐标,step为步数,num为当前路径代表的值
	
	if(step == 6) {//step初始值为1,所以等于6时return
		se.insert(num);
		return;
	}
	int nx, ny;
	for(int i = 0; i < 4; i++) {
		nx = x + dt[i][0];
		ny = y + dt[i][1];
		if(nx >= 0 && nx < 5 && ny >= 0 && ny < 5) {//没有出界
			step++;
			dfs(nx, ny, step, num * 10 + mp[nx][ny]);
			step--;//回溯
		}
	}
	return;
}
int main() {
	
	for(int i = 0; i < 5; i++)
		for(int j = 0; j < 5; j++)
			cin >> mp[i][j];
	for(int i = 0; i < 5; i++)
		for(int j = 0; j < 5; j++)
			dfs(i, j, 1, mp[i][j]);
	cout << se.size() << endl;
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值