Six Degrees of Cowvin Bacon(最短路)

原题链接
Six Degrees of Cowvin Bacon
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 4687 Accepted: 2233
Description

The cows have been making movies lately, so they are ready to play a variant of the famous game “Six Degrees of Kevin Bacon”.

The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one ‘degree’ away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two ‘degrees’ away from each other (counted as: one degree to the cow they’ve worked with and one more to the other cow). This scales to the general case.

The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2…M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.
    Output

  • Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
    Sample Input

4 2
3 1 2 3
2 3 4
Sample Output

100
Hint

[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 – a mean of 1.00 .]
Source

USACO 2003 March Orange

//http://poj.org/problem?id=2139
#include <algorithm>
#include <iostream>
#include <utility>
#include <sstream>
#include <cstring>
#include <cstdio>
#include <vector>
#include <queue>
#include <stack>
#include <cmath>
#include <map>
#include <set>
using namespace std;

typedef long long ll;
const int MOD = int(1e9) + 7;
//int MOD = 99990001;
const int INF = 0x3f3f3f3f;
const ll INFF = (~(0ULL)>>1);
const double EPS = 1e-9;
const double OO = 1e20;
const double PI = acos(-1.0); //M_PI;
const int fx[] = {-1, 1, 0, 0};
const int fy[] = {0, 0, -1, 1};
const int maxn=300 + 20;
int d[maxn][maxn];
int x[maxn];
int n,m;
void floyd_warshall(){
        for(int i=0;i<n;i++){
                for(int j=0;j<n;j++){
                        for(int k=0;k<n;k++){
                                d[i][j]=min(d[i][j],d[i][k] + d[k][j]);
                        }
                }
        }
}
int main(){
        cin >> n >> m;
        for(int i=0;i<maxn;i++)
                for(int j=0;j<maxn;j++)
                        d[i][j]=INF;
        for(int i=0;i<n;i++){
                d[i][i]=0;
        }
        while(m--){
                int c;cin >> c;
                for(int i=0;i<c;i++){
                        cin >> x[i];
                        x[i]--;
                }
                for(int i=0;i<c;i++){
                        for(int j=i+1;j<c;j++){
                                d[x[i]][x[j]] = 1;d[x[j]][x[i]] = 1;
                        }
                }
        }
        floyd_warshall();
        int res=INF;
        for(int i=0;i<n;i++){
                int sum=0;
                for(int j=0;j<n;j++)
                        sum += d[i][j];
                res=min(res,sum);
        }
        cout << res*100/(n-1) << endl;
        return 0;
}
//上面的代码迷之WA,而下面的代码却AC了,始终想不明白原因
/*
#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
int n,m,cow[305][305],mo[305];
const int MAX=100000;
int main()
{
    cin>>n>>m;
    for(int i=0;i<=n;i++)
    {
         fill(cow[i],cow[i]+n+1,MAX);
         cow[i][i]=0;
    }

    while(m--)
    {
        int num;
        scanf("%d",&num);
        for(int i=0;i<num;i++)
            scanf("%d",&mo[i]);
        for(int i=0;i<num;i++)
            for(int j=i+1;j<num;j++)
            {
                 cow[mo[i]-1][mo[j]-1]=1;
                 cow[mo[j]-1][mo[i]-1]=1;
            }

    }
    for(int k=0;k<n;k++)
        for(int i=0;i<n;i++)
        for(int j=0;j<n;j++)
        cow[i][j]=min(cow[i][j],cow[i][k]+cow[k][j]);
        int msum=1000000;
    for(int i=0;i<n;i++)
    {
        int sum=0;
        for(int j=0;j<n;j++)
            sum+=cow[i][j];
        if(sum<msum)
            msum=sum;
    }
      printf("%d\n",msum*100/(n-1));

    return 0;
}
*/

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

门豪杰

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值