Command Network
Description After a long lasting war on words, a war on arms finally breaks out between littleken’s and KnuthOcean’s kingdoms. A sudden and violent assault by KnuthOcean’s force has rendered a total failure of littleken’s command network. A provisional network must be built immediately. littleken orders snoopy to take charge of the project. With the situation studied to every detail, snoopy believes that the most urgent point is to enable littenken’s commands to reach every disconnected node in the destroyed network and decides on a plan to build a unidirectional communication network. The nodes are distributed on a plane. If littleken’s commands are to be able to be delivered directly from a node A to another node B, a wire will have to be built along the straight line segment connecting the two nodes. Since it’s in wartime, not between all pairs of nodes can wires be built. snoopy wants the plan to require the shortest total length of wires so that the construction can be done very soon. Input The input contains several test cases. Each test case starts with a line containing two integer N (N ≤ 100), the number of nodes in the destroyed network, and M (M ≤ 104), the number of pairs of nodes between which a wire can be built. The next N lines each contain an ordered pair xi and yi, giving the Cartesian coordinates of the nodes. Then follow M lines each containing two integers i and j between 1 and N (inclusive) meaning a wire can be built between node i and node j for unidirectional command delivery from the former to the latter. littleken’s headquarter is always located at node 1. Process to end of file. Output For each test case, output exactly one line containing the shortest total length of wires to two digits past the decimal point. In the cases that such a network does not exist, just output ‘ Sample Input 4 6 0 6 4 6 0 0 7 20 1 2 1 3 2 3 3 4 3 1 3 2 4 3 0 0 1 0 0 1 1 2 1 3 4 1 2 3 Sample Output 31.19 poor snoopy Source
POJ Monthly--2006.12.31, galaxy
|
[Submit] [Go Back] [Status] [Discuss]
#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <sstream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <fstream>
#include <numeric>
#include <iomanip>
#include <bitset>
#include <list>
#include <stdexcept>
#include <functional>
#include <utility>
#include <ctime>
using namespace std;
#define PB push_back
#define MP make_pair
#define CLR(vis) memset(vis,0,sizeof(vis))
#define MST(vis,pos) memset(vis,pos,sizeof(vis))
#define MAX3(a,b,c) max(a,max(b,c))
#define MAX4(a,b,c,d) max(max(a,b),max(c,d))
#define MIN3(a,b,c) min(a,min(b,c))
#define MIN4(a,b,c,d) min(min(a,b),min(c,d))
#define PI acos(-1.0)
#define INF 0x7FFFFFFF
#define LINF 1000000000000000000LL
#define eps 1e-8
typedef long long ll;
typedef unsigned long long ull;
const int N=111;
const int M=N*N;
struct node{
double x,y;
}p[N];
struct edge{
int u,v;
double cost;
}e[M];
double In[N];
int ID[N];
int vis[N];
int pre[N];
int n,m;
double len(node a,node b)
{
return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double Directed_MST(int root)
{
double ret=0;
int u,v;
while(true)
{
for(int i=0;i<n;i++)
In[i]=INF;
for(int i=0;i<m;i++)
{
u=e[i].u;
v=e[i].v;
if(e[i].cost<In[v] && u!=v)
{
In[v]=e[i].cost;
pre[v]=u;
}
}
for(int i=0;i<n;i++)
{
if(i==root)
continue;
if(In[i]==INF)
return -1;
}
int cnt=0;
MST(ID,-1);
MST(vis,-1);
In[root]=0;
for(int i=0;i<n;i++)
{
ret+=In[i];
int v=i;
while(vis[v]!=i && ID[v]==-1 && v!=root)
{
vis[v]=i;
v=pre[v];
}
if(v!=root && ID[v]==-1)
{
for(u=pre[v];u!=v;u=pre[u])
{
ID[u]=cnt;
}
ID[v]=cnt++;
}
}
if(cnt==0)
break;
for(int i=0;i<n;i++)
{
if(ID[i]==-1)
ID[i]=cnt++;
}
for(int i=0;i<m;i++)
{
v=e[i].v;
e[i].u=ID[e[i].u];
e[i].v=ID[e[i].v];
if(e[i].u!=e[i].v)
{
e[i].cost-=In[v];
}
}
n=cnt;
root=ID[root];
}
return ret;
}
int main()
{
while(scanf("%d%d",&n,&m)!=EOF)
{
for(int i=0;i<n;i++)
scanf("%lf%lf",&p[i].x,&p[i].y);
for(int i=0;i<m;i++)
{
scanf("%d%d",&e[i].u,&e[i].v);
e[i].u--;
e[i].v--;
if(e[i].u!=e[i].v)
e[i].cost=len(p[e[i].u], p[e[i].v]);
else
e[i].cost=INF;
}
double ans=Directed_MST(0);
if(ans==-1)
printf("poor snoopy\n");
else
printf("%.2f\n", ans);
}
return 0;
}