HDU 4821 String 字符串哈希

String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 937    Accepted Submission(s): 270


Problem Description
Given a string S and two integers L and M, we consider a substring of S as “recoverable” if and only if
  (i) It is of length M*L;
  (ii) It can be constructed by concatenating M “diversified” substrings of S, where each of these substrings has length L; two strings are considered as “diversified” if they don’t have the same character for every position.

Two substrings of S are considered as “different” if they are cut from different part of S. For example, string "aa" has 3 different substrings "aa", "a" and "a".

Your task is to calculate the number of different “recoverable” substrings of S.
 

Input
The input contains multiple test cases, proceeding to the End of File.

The first line of each test case has two space-separated integers M and L.

The second ine of each test case has a string S, which consists of only lowercase letters.

The length of S is not larger than 10^5, and 1 ≤ M * L ≤ the length of S.
 

Output
For each test case, output the answer in a single line.
 

Sample Input
  
  
3 3 abcabcbcaabc
 

Sample Output
  
  
2
 

Source
 



#include <cstdlib>
#include <cctype>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <vector>
#include <string>
#include <iostream>
#include <map>
#include <set>
#include <queue>
#include <stack>
#include <bitset>

using namespace std;

#define PB push_back
#define MP make_pair
#define REP(i,n) for(int i=0;i<(n);++i)
#define FOR(i,l,h) for(int i=(l);i<=(h);++i)
#define DWN(i,h,l) for(int i=(h);i>=(l);--i)
#define CLR(vis,pos) memset(vis,pos,sizeof(vis))
#define PI acos(-1.0)
#define INF 0x3f3f3f3f
#define LINF 1000000000000000000LL

typedef unsigned long long ull;

const int maxn=1e5+100;

ull base=31;
ull nbase[maxn],nhash[maxn];
char s[maxn];
int M,L;
map<ull,int> p;

int main ()
{
    nbase[0]=1;
    FOR(i,1,maxn-1) nbase[i]=nbase[i-1]*base;
    while(scanf("%d%d%s",&M,&L,s)!=EOF){
        int len=strlen(s);
        nhash[len]=0;
        DWN(i,len-1,0)
         nhash[i]=nhash[i+1]*base+s[i]-'a'+1;
        int ans=0;
        ull tmp;
        for(int i=0;i<L && i+M*L<=len;i++){
            p.clear();
            for(int j=i;j<i+M*L;j+=L){
                tmp=nhash[j]-nhash[j+L]*nbase[L];
                p[tmp]++;
            }
            if(p.size()==M) ans++;
            for(int j=i+M*L;j+L<=len;j+=L){
                tmp=nhash[j-M*L]-nhash[j-(M-1)*L]*nbase[L];
                p[tmp]--;
                if(p[tmp]==0) p.erase(tmp);
                tmp=nhash[j]-nhash[j+L]*nbase[L];
                p[tmp]++;
                if(p.size()==M) ans++;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值