任意多边形计算

首先,求一个n边形的面积,顶点(p1,p2,…pn),这些点必须是按顺时针或逆时针排列,也就是点与点之间必须相邻。这里只谈公式我自己用的
在这里插入图片描述
至于这个公式的原理,在这里推荐一个链接:https://blog.csdn.net/LemonGirl131/article/details/51130659?utm_medium=distribute.pc_relevant_t0.none-task-blog-BlogCommendFromMachineLearnPai2-1.nonecase&depth_1-utm_source=distribute.pc_relevant_t0.none-task-blog-BlogCommendFromMachineLearnPai2-1.nonecase
还有就是这里有一道模板题,代码可一参考一下。

Description
Calculus is the first lesson Jason had. It is tedious, so an interesting idea occurred to Jason. He took out his mobile phone and open the HDUOJ and found a water problem. He said to himself, “I must solve this f**king easy water problem in ten minutes! ”.
You were invited to compete with him online. Don’t be defeated.

Input
Multiple test cases, Each test first contains an integer N(3<=N<=100000) indicating the number of vertices of the polygon. The i-th of the following N lines contains two integers xi and yi (0<=xi,yi<=10^9) separated by a blank. (xi,yi) is the i-th vertex of the polygon, and (x1,y1),…,(xn,yn) will be in counterclockwise order.

Output
For each test case, output a number as the answer which is the area of the polygon be multiplied by 2. In case the answer is greater than 1000000006, please modulo the answer with 1000000007.

Sample Input
3
0 0
1 0
0 1
4
0 0
1 0
1 1
0 1

Sample Output
1
2

#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cmath>
#include <cstring>
#include <stack>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <ctype.h>
using namespace std;
typedef long long ll;
const ll N=10005;
const ll inf=1 << 29;
const ll mod=1e9+7;
#define mem(a,b) memset(a,b,sizeof(a))
struct node {
    ll x;
    ll y;
}a[100005];
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        mem(a,0);
        for(int i=1;i<=n;++i)
        {
            scanf("%lld %lld",&a[i].x,&a[i].y);
        }
        ll ans=0;
        for(int i=1;i<=n-1;++i)
        {
            ans=(ans+(a[i].x*a[i+1].y-a[i+1].x*a[i].y)%mod+mod)%mod;
        }
        ans=(ans+(a[n].x*a[1].y-a[1].x*a[n].y)%mod+mod)%mod;
        printf("%lld\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值