hdu 2612 Find a way

http://acm.split.hdu.edu.cn/showproblem.php?pid=2612




Problem Description
Pass a year learning in Hangzhou, yifenfei arrival hometown Ningbo at finally. Leave Ningbo one year, yifenfei have many people to meet. Especially a good friend Merceki.
Yifenfei’s home is at the countryside, but Merceki’s home is in the center of city. So yifenfei made arrangements with Merceki to meet at a KFC. There are many KFC in Ningbo, they want to choose one that let the total time to it be most smallest.
Now give you a Ningbo map, Both yifenfei and Merceki can move up, down ,left, right to the adjacent road by cost 11 minutes.
 

Input
The input contains multiple test cases.
Each test case include, first two integers n, m. (2<=n,m<=200).
Next n lines, each line included m character.
‘Y’ express yifenfei initial position.
‘M’    express Merceki initial position.
‘#’ forbid road;
‘.’ Road.
‘@’ KCF
 

Output
For each test case output the minimum total time that both yifenfei and Merceki to arrival one of KFC.You may sure there is always have a KFC that can let them meet.
 

Sample Input
  
  
4 4 Y.#@ .... .#.. @..M 4 4 Y.#@ .... .#.. @#.M 5 5 Y..@. .#... .#... @..M. #...#
 

Sample Output
  
  
66 88 66
 



#include<cstdio>
#include<cstdlib>
#include<math.h>
#include<iostream>
#include<algorithm>
#include<cstring>
#include<string>
#include<set>
#include<vector>
#include<queue>
#include<map>
#define ms(x) memset( (x),0,sizeof(x) );
using namespace std;
typedef long long int ll;
int n,m;
char v[222][222];
int vis[2][222][222];
struct node{
	int x,y,step;
	node(int tx,int ty,int ts){
		x=tx,y=ty,step=ts;
	}	
	bool operator < (const node &a) const{
		return a.step<step;
	}
};
int check(int x,int y){
	if( x < 1 || x > n ) return 1;
	if( y < 1 || y > m ) return 1;
	if( v[x][y] == '#' ) return 1;
	return 0;
}
int k[4][2]={ 1,0,-1,0,0,1,0,-1 };
void bfs(int x,int y,int tt){
	priority_queue<node> q;
	q.push( node(x,y,0) );
	vis[tt][x][y] = 0;
	while(!q.empty()){
		node t = q.top();	q.pop();
		for(int i = 0;i < 4;i++){
			int tx=t.x+k[i][0];
			int ty=t.y+k[i][1];
			if( check(tx,ty) ) continue;
			if( vis[tt][tx][ty] > t.step+1 ){
				vis[tt][tx][ty] = t.step+1;
				q.push( node( tx,ty,t.step+1 ) );
			}
		}
	}
}
int main()
{
//	freopen("E:\\workspace\\acm---C++\\acm\\1.txt","r",stdin);
	while(scanf("%d%d",&n,&m)!=EOF){
		ms(v);memset(vis,0x3f,sizeof(vis));//这里初始化为7f是会wa     可能是溢出?   因为这个wa的火大
//		printf("------%d-------%d---------------\n",vis[0][0][0],vis[0][0][0]+vis[0][0][0]);
		for(int i = 1;i <= n;i++){
			scanf("%s",v[i]+1);
		}
		for(int i = 1;i <= n;i++){
			for(int j = 1;j <= m;j++){
				if( v[i][j] == 'M' ) bfs(i,j,0);
				if( v[i][j] == 'Y' ) bfs(i,j,1);
			}
		}
		int ans = 0x7f3f3f3f;
		for(int i = 1;i <= n;i++){
			for(int j = 1;j <= m;j++){
				if( v[i][j]=='@' ) ans = min(ans,vis[0][i][j]+vis[1][i][j]);
			}
		}
		printf("%d\n",ans*11);
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值