lightoj 1341在一定条件下计算因数对个数

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.
Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.
Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.
Input
Input starts with an integer T (≤ 4000), denoting the number of test cases.
Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.
Output
For each case, print the case number and the number of possible carpets.
Sample Input
2
10 2
12 2
Sample Output
Case 1: 1
Case 2: 2
计算一个数字的因数个数的原理是判断这个数字可有多少个质数相乘的到,而因数个数就是这些次方+1在相乘,便得到因素和。
像100=2的平方 X 5的平方;
100的因数为 1 2 4 5 10 20 25 50 100 共9个;
即(2+1)*(2+1)=3;

#include <bits/stdc++.h>
#include <iostream>
#define ll long long
using namespace std;
ll x,y,z,i,j,m,n,sum,a[1800008],b[1800008],t,o;
int main()
{
    for(i=2; i<=1200000; i++)
        if(a[i]==0)
        {
            b[++m]=i;
            for(j=i+i; j<=1200000; j=j+i)
                a[j]=1;
        }//素数筛
    cin>>t;
    while(t--)
    {
        sum=1;
        scanf("%lld %lld",&x,&y);
        if(y*y>=x)sum=0;
        else
        {
            n=x;
            for(i=1; i<=m&&b[i]<x; i++)
            {
                j=1;
                while(x%b[i]==0)
                {
                    x=x/b[i];
                    j++;
                }
                sum*=j;
            }
            if(x!=1)sum*=2;//个人认为最重要的便是这一步,因为我们的数组a最大也就到1200000,但是比1200000大的质数还是有的,当输入的数字x为大于12000000的质数时,我们将无法判断,所以仅判断最后退出的x是不是1就可以判断它是不是合法退出的,即还有没有为除完的项,如果有就再乘以二。
            sum=sum/2;//因为没有正方形,则不用管sum是奇数还是偶数。
            for(i=1; i<y; i++)
                if(n%i==0)sum--;//有的人可能要问,我直接判断到y不会多减去吗?但是我们早在上面就判断了,y*y<x,即y<sqrt(x);则不会减去多的数。
        }
        printf("Case %lld: %lld\n",++o,sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值