杭电OJ --1002

A + B Problem II

Problem Description:

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input:

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output:

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input:

2
1 2
112233445566778899 998877665544332211

Sample Output:

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

Code:

#include <iostream>
#include <string>
using namespace std;

string add(string a, string b)
{
    int CF = 0;
    int a_len = a.length();
    int b_len = b.length();
    int max_len = a_len > b_len ? a_len : b_len;
    string result = "";
    for(int i = 0; i < max_len;i++)
    {
        char num1 = i < a.length() ? a[i] : '0';
        char num2 = i < b.length() ? b[i] : '0';
        char sum = num1 + num2 + CF - '0';
        CF = 0;
        if(sum > '9')
        {
            CF = 1;
            sum = sum - 10;
        }
        result = result + sum;
    }
    return result;
}

string reverse(string str)
{
    string result = str;
    for (int i = 0; i < str.length(); i++)
    {
        result[i] = str[str.length() - i -1];
    }
    return result;
}

int main()
{
    int n;
    cin>>n;
    for(int i = 1; i <= n; i++)
    {
        string a,b;
        cin>>a>>b;
        string sum = reverse(add(reverse(a),reverse(b)));
        cout<<"Case "<<i<<":"<<endl;
        cout<<a<<" + "<<b<<" = "<<sum<<endl;
        if(i != n)
            cout<<endl;
    }
    return 0;
}

Tip:

本题的重点是如何处理大数相加,我采取的策略是:

  • 使用string保存大数
  • 然后通过reverse()函数进行反转。
  • 分别从string a,b的地位开始进行加法
  • CF保存进位信息
  • 当前计算位 > = a/b.length()是使用’0’作为加数
  • 由于string采用char进行每位的存储,在计算num1+num2+CF之后需要减去’0’(’1’+’2’!=’3’,’1’+’2’-’0’=’3’)
  • 最后一个case只需要进行一次换行
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值