杭电oj1003 - MAX SUM & LeedCode #53 最大子数组和

一、杭电oj1003 - MAX SUM

Problem Description

Given a sequence a[1],a[2],a[3]…a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output

Case 1:
14 1 4

Case 2:
7 1 6

代码

#include <iostream>
using namespace std;

int main() {
	int group[100000];
	int num;
	cin >> num;

	for (int i = 1; i <= num; i++) {
		int n, sum = 0, maxsum = -100000; // 一个绝对小的数
		int start = 0, end = 0;
		cin >> n;
		for (int j = 0; j < n; j++) {
			cin >> group[j];
		}
		int k = 1;  // 从第二个数开始
		for (int j = 0; j < n; j++) {
			sum += group[j];
			if (maxsum < sum) {
				maxsum = sum;
				end = j + 1;
				// 第几个数是下标+1
				start = k;
			}
			if (sum < 0) {
				sum = 0;
				k = j + 2;
				// 和小于0,就从之后的数开始
			}
		}
		cout << "Case " << i << ":" << endl;
		cout << maxsum << " " << start << " " << end << endl;
		if (i != num)
			cout << endl;
	}

	return 0;
}

二、LeedCode #53 最大子数组和

题目

给你一个整数数组 nums ,请你找出一个具有最大和的连续子数组(子数组最少包含一个元素),返回其最大和。

子数组 是数组中的一个连续部分。

示例

示例 1:
输入:nums = [-2,1,-3,4,-1,2,1,-5,4]
输出:6
解释:连续子数组 [4,-1,2,1] 的和最大,为 6 。

示例 2:
输入:nums = [1]
输出:1

示例 3:
输入:nums = [5,4,-1,7,8]
输出:23

提示:

1 <= nums.length <= 105
-104 <= nums[i] <= 104

class Solution {
public:
    int maxSubArray(vector<int>& nums) {
        int result = INT32_MIN; // 最先赋值为一个最小的数
        int count = 0;
        for (int i = 0; i < nums.size(); i++) {
            count += nums[i];
            if (count > result) {
                result = count;
            }
            if (count <= 0) count = 0; // 遇到负数重置起点
        }
        return result;
    }
};

小结

两道题都是求最大子序和,用的都是贪心算法,小细节上有点不同。

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值