Cow Contest
N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.
The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.
Farmer John is trying to rank the cows by skill level. Given a list the results of M(1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B
Output
* Line 1: A single integer representing the number of cows whose ranks can be determined
Sample Input
5 5
4 3
4 2
3 2
1 2
2 5
Sample Output
2
题意:n头牛,给出一部分牛的排名情况,求最后确定排名的牛的头数
这道题压根就不是什么最短路问题,而是通过Floyd的模板来构建传递闭包
用floyed求传递闭包。如果一个牛和其余的牛关系都是确定的,那么这个牛的排名就是确定的了
也就是说 该牛能够击败的牛的数量+该牛被其他牛击败的数量=所有牛的数量-1
传递闭包的含义指通过传递性推导出尽量多的元素之间的关系,而传递闭包一般都是采用floyd算法。
抽象为简单的floyd传递闭包算法,在加上每个顶点的出度与入度 (出度+入度=顶点数-1,则能够确定其编号)。
对于传递闭包举个栗子:1号打败2号,2号能打败3号,那么1号就能打败3号,这就是传递性
#include <iostream>
#include<queue>
#include <string>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include<cstdlib>
#include<cmath>
using namespace std;
#define rep(i,a,b) for(int i=a;i<=b;i++)
const int INF=0x3f3f3f3f;
//struct node
//{
// int u,v,w;
//}num[2550];
int dis[200];
int n;
int e[200][200];
int a[600];
int vis[600];
void Floyed()
{
rep(k,1,n)
rep(i,1,n)
rep(j,1,n)
e[i][j]=e[i][j]||(e[i][k]&&e[k][j]);//实现传递闭包
}
int main()
{
int m;
scanf("%d%d",&n,&m);
memset(e,0,sizeof e);
rep(i,1,m)
{
int x,y;
scanf("%d%d",&x,&y);
e[x][y]=1;//对每给出的一次击败关系建立单向边
}
Floyed();
int ans=0;
rep(i,1,n)
{
int tot=0;
rep(j,1,n)
if(i!=j)
tot=tot+(e[i][j]||e[j][i]);//如果和其他牛的关系确定,即确定数为n-1,就说明它的排名可以确定
if(tot==n-1)
ans++;
}
printf("%d\n",ans);
return 0;
}