Floyd传递闭包

Median Weight Bead

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 4170 Accepted: 2159

Description

There are N beads which of the same shape and size, but with different weights. N is an odd number and the beads are labeled as 1, 2, ..., N. Your task is to find the bead whose weight is median (the ((N+1)/2)th among all beads). The following comparison has been performed on some pairs of beads: 
A scale is given to compare the weights of beads. We can determine which one is heavier than the other between two beads. As the result, we now know that some beads are heavier than others. We are going to remove some beads which cannot have the medium weight. 

For example, the following results show which bead is heavier after M comparisons where M=4 and N=5. 

1.	Bead 2 is heavier than Bead 1.

2.	Bead 4 is heavier than Bead 3.

3.	Bead 5 is heavier than Bead 1.

4.	Bead 4 is heavier than Bead 2.


From the above results, though we cannot determine exactly which is the median bead, we know that Bead 1 and Bead 4 can never have the median weight: Beads 2, 4, 5 are heavier than Bead 1, and Beads 1, 2, 3 are lighter than Bead 4. Therefore, we can remove these two beads. 

Write a program to count the number of beads which cannot have the median weight. 

Input

The first line of the input file contains a single integer t (1 <= t <= 11), the number of test cases, followed by the input data for each test case. The input for each test case will be as follows: 
The first line of input data contains an integer N (1 <= N <= 99) denoting the number of beads, and M denoting the number of pairs of beads compared. In each of the next M lines, two numbers are given where the first bead is heavier than the second bead. 

Output

There should be one line per test case. Print the number of beads which can never have the medium weight.

Sample Input

1
5 4
2 1
4 3
5 1
4 2

Sample Output

2

Source

Tehran Sharif 2004 Preliminary

通过此题记一个模板

题意:

        有N(N为奇数)个珠子,我们进行了M次重量的比较且给出了结果.我们想找出这N个珠子中重量居中的那个珠子(中位数),即有(N+1)/2个珠子比它重,有(N+1)/2个珠子比它轻的那个珠子.但是我们得先排除那些已经能确定不是中位数的珠子.

分析:

        那些肯定不是中位数的珠子一定是比它重的珠子或比它轻的珠子数>=(N+1)/2

        首先我们通过Floyd传递闭包,用mp[i][j]=1表示珠子i比j重.mp[i][j]=0表i与j的关系不明确. 我们求出所有可能的mp关系.

        然后通过枚举,比如mp[i][j]=1的话,i节点的出度+1,j节点的入度+1.如果某个节点的出度或入度>=(N+1)/2,那么这个节点肯定要被排除.

AC代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int maxn=100+10;
int mp[maxn][maxn];
int main()
{
    int T; scanf("%d",&T);
    while(T--)
    {
        int n,m;
        scanf("%d%d",&n,&m);
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            mp[i][j]= i==j?1:0;
        while(m--)
        {
            int u,v;
            scanf("%d%d",&u,&v);
            mp[u][v]=1;
        }
        for(int k=1;k<=n;k++)
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
            mp[i][j] |=mp[i][k]&mp[k][j];
        int in[maxn],out[maxn];
        memset(in,0,sizeof(in));
        memset(out,0,sizeof(out));
        for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)if(i!=j&&mp[i][j])
        {
            ++in[j],++out[i];
        }
        int ans=0;
        for(int i=1;i<=n;i++)if(in[i]>=(n+1)/2 || out[i]>=(n+1)/2)
            ++ans;
        printf("%d\n",ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值