POJ 1703 种类并查集(并查集进阶)

The police office in Tadu City decides to say ends to the chaos, as launch actions to root up the TWO gangs in the city, Gang Dragon and Gang Snake. However, the police first needs to identify which gang a criminal belongs to. The present question is, given two criminals; do they belong to a same clan? You must give your judgment based on incomplete information. (Since the gangsters are always acting secretly.) 

Assume N (N <= 10^5) criminals are currently in Tadu City, numbered from 1 to N. And of course, at least one of them belongs to Gang Dragon, and the same for Gang Snake. You will be given M (M <= 10^5) messages in sequence, which are in the following two kinds: 

1. D [a] [b] 
where [a] and [b] are the numbers of two criminals, and they belong to different gangs. 

2. A [a] [b] 
where [a] and [b] are the numbers of two criminals. This requires you to decide whether a and b belong to a same gang. 

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. Each test case begins with a line with two integers N and M, followed by M lines each containing one message as described above.

Output

For each message "A [a] [b]" in each case, your program should give the judgment based on the information got before. The answers might be one of "In the same gang.", "In different gangs." and "Not sure yet."

Sample Input

1
5 5
A 1 2
D 1 2
A 1 2
D 2 4
A 1 4

Sample Output

Not sure yet.
In different gangs.
In the same gang.

 

题目大意:有两个帮会,然后输入格式为D a b 表示ab两个人不是一个帮派,输入格式为A  a  b是让输入ab两个人是不是一个帮会的,是就输出In the ……,不是的话就是输出In different ……,如果单凭当前的相对关系不能够判断两人的所在帮派,那就输出Not sure ……

这一题和POJ1182有点类似,但是这一个好做一点

并查集可以将两个有同一种关系的元素归并到一个集合当中,这道题目不好处理的就是每次输入的关系正好与并查集的处理相反,可以这样来处理:

给出ab,那么ab肯定是两个帮派里的,假设存在两个帮会AB,因此a有可能是A,也有可能是B帮会,那就需要将这两种情况全部都考虑进去,规定(a+n,b)表示a属于B帮派,b属于A帮派,(a,b+n)表示a属于A帮派,b属于B帮派,那么开始预处理就要由1--n,处理到1--2*n,这样就能将两种情况全部考虑进去,剩下的就是并查集的板子

#include <iostream>
#include <algorithm>
#include <queue>
#include<cstring>
#include<cstdio>
#include<cmath>
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define init(i,a) memset(i,a,sizeof i)
using namespace std;
const int INF=0x3f3f3f3f;
const int N=1e5+10;
int f[N<<1];
bool vis[N];
int Findf(int v){
    return f[v]==v?v:f[v]=Findf(f[v]);
}
void Merge(int x,int y){
    int t1=Findf(x);
    int t2=Findf(y);
    if(t1!=t2){
        f[t2]=t1;
    }
    return ;
}
bool Same(int x,int y)
{
    return Findf(x)==Findf(y);
}
int main()
{
#ifndef ONLINE_JUDGE
	freopen("in.txt", "r", stdin);
#endif
   int T;
   scanf("%d",&T);
   int n,m;
   while(T--){
    init(vis,0);init(f,0);
    scanf("%d%d\n",&n,&m);
    rep(i,1,2*n) f[i]=i;
    char ch;int x,y;
    rep(i,1,m){
        scanf("%c %d %d\n",&ch,&x,&y);
                if(ch=='A'){
            if(Same(x,y)) printf("In the same gang.\n");
            else if(Same(x+n,y)||Same(x,y+n)) printf("In different gangs.\n");
            else {printf("Not sure yet.\n");continue;}
        }else{
            Merge(x+n,y);
            Merge(x,y+n);
        }
    }
   }
	return 0;
}

这道题还有另外一种方法

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值