POJ - 3041(最小点覆盖数)

Asteroids
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 27321 Accepted: 14671
Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid.

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.
Input

  • Line 1: Two integers N and K, separated by a single space.

  • Lines 2…K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.
    Output

  • Line 1: The integer representing the minimum number of times Bessie must shoot.
    Sample Input

3 4
1 1
1 3
2 2
3 2
Sample Output

2
Hint

INPUT DETAILS:
The following diagram represents the data, where “X” is an asteroid and “.” is empty space:
X.X
.X.
.X.

OUTPUT DETAILS:
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
题目大意: 有一个N*N的网格,该网格有K个障碍物.你有一把武器,每次你使用武器可以清楚该网格特定行或列的所有障碍.问你最少需要使用多少次武器能清除网格的所有障碍物?
分析:参考分析:https://www.cnblogs.com/bofengyu/p/4978213.html
大家先看一个图
在这里插入图片描述
大家看最左边的那个连线图,对于那两个圈住的两个点就是我们要射击的所在的行或者列,那么这个题目就转化成最小点覆盖问题(就是求最小的点,能够将这个图中左右的线全部包含住的点),然后又根据:
最大匹配数 = 最小顶点覆盖(选取最少的点,使得点集中的点能覆盖所有的边)

证明:首先要明确的一点是最小顶点覆盖一定不会小于最大匹配数。显而易见,最大匹配中的每一个匹配都是不相邻的一条边,如果最大匹配数为n,那么至少需要n个顶点来覆盖这n条边。
那么依据这个定理的话剩下的就是套用匈牙利算法来做了

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<deque>
#include<cstring>
using namespace std;
#define rep(i,a,b) for(int i=a;i<=b;i++)
typedef long long ll;
const int INF=0x3f3f3f3f;
int e[600][600];
bool vis[10009];
int sx[10010];
int n,k;
bool dfs(int u){
    rep(i,1,n){
        if(!vis[i]&&e[u][i]){
            vis[i]=1;
            if(!sx[i]||dfs(sx[i])){
                sx[i]=u;
                return true;
            }
        }
    }
    return false;
}
int hungary(){
    int ans=0;
    rep(i,1,n){
        memset(vis,0,sizeof vis);
        if(dfs(i)) ans++;
    }
    return ans;
}
int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    scanf("%d%d",&n,&k);
    rep(i,1,k){int u,v;
    scanf("%d%d",&u,&v);
    e[u][v]=1;
    }
    cout<<hungary()<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值