二维前缀和


Monitor

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 163840/163840 K (Java/Others)
Total Submission(s): 514 Accepted Submission(s): 160

Problem Description

Xiaoteng has a large area of land for growing crops, and the land can be seen as a rectangle of n×m .

But recently Xiaoteng found that his crops were often stolen by a group of people, so he decided to install some monitors to find all the people and then negotiate with them.

However, Xiao Teng bought bad monitors, each monitor can only monitor the crops inside a rectangle. There are p monitors installed by Xiaoteng, and the rectangle monitored by each monitor is known.

Xiao Teng guess that the thieves would also steal q times of crops. he also guessed the range they were going to steal, which was also a rectangle. Xiao Teng wants to know if his monitors can see all the thieves at a time.

Input

There are mutiple test cases.

Each case starts with a line containing two integers n,m(1≤n,1≤m,n×m≤107) which represent the area of the land.

And the secend line contain a integer p(1≤p≤106) which represent the number of the monitor Xiaoteng has installed. This is followed by p lines each describing a rectangle. Each of these lines contains four intergers x1,y1,x2 and y2(1≤x1≤x2≤n,1≤y1≤y2≤m) ,meaning the lower left corner and upper right corner of the rectangle.

Next line contain a integer q(1≤q≤106) which represent the number of times that thieves will steal the crops.This is followed by q lines each describing a rectangle. Each of these lines contains four intergers x1,y1,x2 and y2(1≤x1≤x2≤n,1≤y1≤y2≤m) ,meaning the lower left corner and upper right corner of the rectangle.

Output

For each case you should print q lines.

Each line containing YES or NO mean the all thieves whether can be seen.

Sample Input

6 6
3
2 2 4 4
3 3 5 6
5 1 6 2
2
3 2 5 4
1 5 6 5

Sample Output

YES
NO

Hint
In the picture,the red solid rectangles mean the monitor Xiaoteng installed, and the blue dotted rectangles mean the area will be stolen.
在这里插入图片描述

题目大意:
给你n和m,表示有一个nm的矩阵(nm<=1e7),初始全0,接下来一个数p(p<=1e6),接下来p个矩阵的左下角和右上角的坐标。

把这位于这些矩阵内的格子置为1,再接下来一个数q(1<=1e6),接下来q个矩阵的左下角和右上角的坐标,对于每个矩阵,如果它包含的每个格子都是1,则输出YES,否则输出NO。
理论基础:
https://blog.csdn.net/k_r_forever/article/details/81775899
分析:
用前缀和的方法计算出每个格子是否被覆盖(p个矩阵都进行二维前缀和的加1更新操作,然后统计一遍前缀和即可得出每个格子是否被覆盖,大于等于1即为被覆盖)

然后把被覆盖的格子都置为1,重新统计一遍前缀和(这时候前缀和就表示矩形(1,1,x,y)包含的被覆盖的格子数了)。方便我们接下来的判断。
还有一点需要注意的就是要动态开辟空间。

#include <iostream>
#include <algorithm>
#include <string>
#include <map>
#include <cstring>
#include <cmath>
#include <queue>
#include <cstdio>
#include <vector>
#include <set>
#include <stack>
using namespace std;
typedef long long ll;
const int N = 1e6+10;
const int INF=0x3f3f3f3f;
const ll LINF=0x3f3f3f3f3f3f3f3f;
const int MOD=1e9+7;
#define rep(i,a,b) for(int i=a;i<=b;i++)
#define Abs(x) ((x)>=0?(x):-(x))

int main()
{
    #ifndef ONLINE_JUDGE
    freopen("in.txt","r",stdin);
    #endif // ONLINE_JUDGE
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){

    int **p=new int*[n+10];
    for(int i=0;i<n+10;i++) p[i] = new int[m+10];
    for(int i=0;i<=n+5;i++)
        for(int j=0;j<=m+5;j++)
            p[i][j]=0;
    int pp,q;
    scanf("%d",&pp);
    ll x1,y1,x2,y2;
    while(pp--){
        scanf("%lld%lld%lld%lld",&x1,&y1,&x2,&y2);
        p[x1][y1]++;p[x2+1][y2+1]++;
        p[x1][y2+1]--;p[x2+1][y1]--;
    }
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        p[i][j]=p[i][j]+p[i-1][j]+p[i][j-1]-p[i-1][j-1];
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
            if(p[i][j]) p[i][j]=1;
    for(int i=1;i<=n;i++)
        for(int j=1;j<=m;j++)
        p[i][j]=p[i][j]+p[i-1][j]+p[i][j-1]-p[i-1][j-1];

    scanf("%d",&q);
    while(q--){
        scanf("%lld%lld%lld%lld",&x1,&y1,&x2,&y2);
        ll ans=p[x2][y2]-p[x2][y1-1]-p[x1-1][y2]+p[x1-1][y1-1];
        
        if(ans==(y2-y1+1)*(x2-x1+1))
            printf("YES\n");
        else
            printf("NO\n");
       }
       for(int i=0;i<n+10;i++)
        delete [] p[i];
       delete []p;
    }
    return 0;
 }

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值