uva 1585 - Score

本博客介绍了一个用于计算测试成绩的程序,程序通过读取输入的测试结果字符串,并根据字符串中的‘O’和‘X’来计算每个问题的分数。分数计算规则为:正确答案得分为自身及连续两个正确的答案数之和。程序会读取多组测试数据并输出每组的最终分数。
摘要由CSDN通过智能技术生成

There is an objective test result such as `OOXXOXXOOO". AnO’ means a correct answer of a problem and an X' means a wrong answer. The score of each problem of this test is calculated by itself and its just previous consecutiveO’s only when the answer is correct. For example, the score of the 10th problem is 3 that is obtained by itself and its two previous consecutive `O’s.

Therefore, the score of OOXXOXXOOO" is 10 which is calculated by1+2+0+0+1+0+0+1+2+3”.

You are to write a program calculating the scores of test results.

Input

Your program is to read from standard input. The input consists of T test cases. The number of test cases T is given in the first line of the input. Each test case starts with a line containing a string composed by O' andX’ and the length of the string is more than 0 and less than 80. There is no spaces between O' andX’.

Output

Your program is to write to standard output. Print exactly one line for each test case. The line is to contain the score of the test case.

The following shows sample input and output for five test cases.

Sample Input

5
OOXXOXXOOO
OOXXOOXXOO
OXOXOXOXOXOXOX
OOOOOOOOOO
OOOOXOOOOXOOOOX

Sample Output

10
9
7
55
30


import java.util.Scanner;

public class Main {

     public static void main(String[] args) {
          Scanner in = new Scanner(System.in);
          int n = in.nextInt();
          String s1 = in.nextLine();
          for (int i = 0; i < n; i++) {
             String s = in.nextLine();
             int count = 0, sum = 0;
             for (int j = 0; j < s.length(); j++) {
                 if (s.charAt(j) == 'O') {
                     count++;
                     sum += count;
                 } else if (s.charAt(j) == 'X')
                     count = 0;
             }
             System.out.println(sum);
         }
     }
 }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值